summaryrefslogtreecommitdiff
path: root/Debian/Debhelper
diff options
context:
space:
mode:
Diffstat (limited to 'Debian/Debhelper')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm9
1 files changed, 8 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 81cff3c9..fd317306 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -155,7 +155,14 @@ sub setup_py {
}
foreach my $python (@python_dbg, @python_requested) {
- if (-f "/usr/lib/$python/distutils/__init__.py") {
+ my $python_with_version = $python;
+ if ($python eq "python") {
+ $python_with_version = $python_default;
+ }
+ elsif ($python eq "python-dbg") {
+ $python_with_version = $python_default."-dbg";
+ }
+ if (-f "/usr/lib/$python_with_version/distutils/__init__.py") {
# To allow backports of debhelper we don't pass
# --install-layout=deb to 'setup.py install` for
# those Python versions where the option is