summaryrefslogtreecommitdiff
path: root/Debian
diff options
context:
space:
mode:
Diffstat (limited to 'Debian')
-rw-r--r--Debian/Debhelper/Buildsystem.pm28
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm4
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm4
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm34
7 files changed, 41 insertions, 41 deletions
diff --git a/Debian/Debhelper/Buildsystem.pm b/Debian/Debhelper/Buildsystem.pm
index 5bebfe2e..d546d20b 100644
--- a/Debian/Debhelper/Buildsystem.pm
+++ b/Debian/Debhelper/Buildsystem.pm
@@ -45,7 +45,7 @@ sub DEFAULT_BUILD_DIRECTORY {
# - builddir - specifies build directory to use. If not specified,
# in-source build will be performed. If undef or empty,
# DEFAULT_BUILD_DIRECTORY will be used.
-# - build_action - set this parameter to the name of the build action
+# - build_step - set this parameter to the name of the build step
# if you want the object to determine its is_buidable
# status automatically (with check_auto_buildable()).
# Do not pass this parameter if is_buildable flag should
@@ -66,9 +66,9 @@ sub new {
$this->{builddir} = $this->DEFAULT_BUILD_DIRECTORY();
}
}
- if (exists $opts{build_action}) {
- if (defined $opts{build_action}) {
- $this->{is_buildable} = $this->check_auto_buildable($opts{build_action});
+ if (exists $opts{build_step}) {
+ if (defined $opts{build_step}) {
+ $this->{is_buildable} = $this->check_auto_buildable($opts{build_step});
}
else {
$this->{is_buildable} = 0;
@@ -84,7 +84,7 @@ sub is_buildable {
}
# This instance method is called to check if the build system is capable
-# to auto build a source package. Additional argument $action describes
+# to auto build a source package. Additional argument $step describes
# which operation the caller is going to perform (either configure,
# build, test, install or clean). You must override this method for the
# build system module to be ever picked up automatically. This method is
@@ -95,7 +95,7 @@ sub is_buildable {
# path to the files in the build directory.
sub check_auto_buildable {
my $this=shift;
- my ($action) = @_;
+ my ($step) = @_;
return 0;
}
@@ -208,20 +208,20 @@ sub clean_builddir {
}
-# Instance method that is called before performing any action (see below).
+# Instance method that is called before performing any step (see below).
# Action name is passed as an argument. Derived classes overriding this
# method should also call SUPER implementation of it.
-sub pre_action {
+sub pre_step {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
}
-# Instance method that is called after performing any action (see below).
+# Instance method that is called after performing any step (see below).
# Action name is passed as an argument. Derived classes overriding this
# method should also call SUPER implementation of it.
-sub post_action {
+sub post_step {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
}
# The instance methods below provide support for configuring,
@@ -229,8 +229,8 @@ sub post_action {
# In case of failure, the method may just error() out.
#
# These methods should be overriden by derived classes to
-# implement buildsystem specific actions needed to build the
-# source. Arbitary number of custom action arguments might be
+# implement buildsystem specific steps needed to build the
+# source. Arbitary number of custom step arguments might be
# passed. Default implementations do nothing.
sub configure {
my $this=shift;
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index fcdc2567..d7018bb2 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -17,10 +17,10 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
# Handle configure; the rest - next class
- if ($action eq "configure") {
+ if ($step eq "configure") {
return -x "configure";
}
return 0;
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 8bdbabbb..bb038727 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -16,9 +16,9 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
my $ret = -e "CMakeLists.txt";
- $ret &&= $this->SUPER::check_auto_buildable(@_) if $action ne "configure";
+ $ret &&= $this->SUPER::check_auto_buildable(@_) if $step ne "configure";
return $ret;
}
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index 244ef30d..4f15152b 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -55,10 +55,10 @@ sub new {
sub check_auto_buildable {
my $this=shift;
- my ($action) = @_;
+ my ($step) = @_;
# Handles build, test, install, clean; configure - next class
- if (grep /^\Q$action\E$/, qw{build test install clean}) {
+ if (grep /^\Q$step\E$/, qw{build test install clean}) {
# This is always called in the source directory, but generally
# Makefiles are created (or live) in the the build directory.
return -e $this->get_buildpath("Makefile") ||
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index ce69f4ce..929d9e90 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -15,11 +15,11 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my ($this, $action) = @_;
+ my ($this, $step) = @_;
# Handles everything
my $ret = -e "Build.PL";
- if ($action ne "configure") {
+ if ($step ne "configure") {
$ret &&= -e "Build";
}
return $ret;
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 46dda4f8..36586e43 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -16,10 +16,10 @@ sub DESCRIPTION {
sub check_auto_buildable {
my $this=shift;
- my ($action)=@_;
+ my ($step)=@_;
# Handles configure, install; the rest - next class
- if ($action eq "install" || $action eq "configure") {
+ if ($step eq "install" || $step eq "configure") {
return -e "Makefile.PL";
}
else {
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index afb03dd7..80b66887 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -45,7 +45,7 @@ sub create_buildsystem_instance {
}
sub load_buildsystem {
- my ($action, $system)=@_;
+ my ($step, $system)=@_;
if (defined $system) {
my $inst = create_buildsystem_instance($system);
return $inst;
@@ -53,7 +53,7 @@ sub load_buildsystem {
else {
# Try to determine build system automatically
for $system (@BUILDSYSTEMS) {
- my $inst = create_buildsystem_instance($system, build_action=>$action);
+ my $inst = create_buildsystem_instance($system, build_step=>$step);
if ($inst->is_buildable()) {
return $inst;
}
@@ -90,24 +90,24 @@ sub buildsystems_init {
}
sub buildsystems_list {
- my $action=shift;
+ my $step=shift;
# List buildsystems (including auto and specified status)
my ($auto, $specified);
for my $system (@BUILDSYSTEMS) {
- my $inst = create_buildsystem_instance($system, build_action => undef);
+ my $inst = create_buildsystem_instance($system, build_step => undef);
my $is_specified = defined $opt_buildsys && $opt_buildsys eq $inst->NAME();
if (! defined $specified && defined $opt_buildsys && $opt_buildsys eq $inst->NAME()) {
$specified = $inst->NAME();
}
- elsif (! defined $auto && $inst->check_auto_buildable($action)) {
+ elsif (! defined $auto && $inst->check_auto_buildable($step)) {
$auto = $inst->NAME();
}
printf("%s - %s\n", $inst->NAME(), $inst->DESCRIPTION());
}
# List a specified 3rd party buildsystem too.
if (! defined $specified && defined $opt_buildsys) {
- my $inst = create_buildsystem_instance($opt_buildsys, build_action => undef);
+ my $inst = create_buildsystem_instance($opt_buildsys, build_step => undef);
printf("%s - %s.\n", $inst->NAME(), $inst->DESCRIPTION());
$specified = $inst->NAME();
}
@@ -119,27 +119,27 @@ sub buildsystems_list {
}
sub buildsystems_do {
- my $action=shift;
+ my $step=shift;
- if (!defined $action) {
- $action = basename($0);
- $action =~ s/^dh_auto_//;
+ if (!defined $step) {
+ $step = basename($0);
+ $step =~ s/^dh_auto_//;
}
- if (grep(/^\Q$action\E$/, qw{configure build test install clean}) == 0) {
- error("unrecognized build action: " . $action);
+ if (grep(/^\Q$step\E$/, qw{configure build test install clean}) == 0) {
+ error("unrecognized build step: " . $step);
}
if ($opt_list) {
- buildsystems_list($action);
+ buildsystems_list($step);
exit 0;
}
- my $buildsystem = load_buildsystem($action, $opt_buildsys);
+ my $buildsystem = load_buildsystem($step, $opt_buildsys);
if (defined $buildsystem) {
- $buildsystem->pre_action($action);
- $buildsystem->$action(@_, @{$dh{U_PARAMS}});
- $buildsystem->post_action($action);
+ $buildsystem->pre_step($step);
+ $buildsystem->$step(@_, @{$dh{U_PARAMS}});
+ $buildsystem->post_step($step);
}
return 0;
}