summaryrefslogtreecommitdiff
path: root/Debian
diff options
context:
space:
mode:
Diffstat (limited to 'Debian')
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm6
-rw-r--r--Debian/Debhelper/Dh_Lib.pm8
2 files changed, 5 insertions, 9 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index 18157bf0..6d545e36 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -148,9 +148,9 @@ sub parseopts {
# packages out, below.
if (! defined $options{DOPACKAGES} || ! @{$options{DOPACKAGES}}) {
if ($options{DOINDEP} || $options{DOARCH} || $options{DOSAME}) {
- # User specified that all arch (in)dep package be
- # built, and there are none of that type.
- error("I have no package to build");
+ # User specified that all arch (in)dep package be
+ # built, and there are none of that type.
+ error("I have no package to build");
}
push @{$options{DOPACKAGES}},GetPackages();
}
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 4140642b..ef924b67 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -383,10 +383,6 @@ sub filearray {
}
}
-sub getcontrol {
- return $ENV{DH_CONTROL} || 'debian/control';
-}
-
# Returns a list of packages in the control file.
# Must pass "arch" or "indep" or "same" to specify arch-dependant or
# -independant or same arch packages. If nothing is specified, returns all
@@ -405,8 +401,8 @@ sub GetPackages {
my $package="";
my $arch="";
my @list=();
- open (CONTROL, getcontrol()) ||
- error("cannot read ".getcontrol().": $!\n");
+ open (CONTROL, 'debian/control') ||
+ error("cannot read debian/control: $!\n");
while (<CONTROL>) {
chomp;
s/\s+$//;