summaryrefslogtreecommitdiff
path: root/Debian
diff options
context:
space:
mode:
Diffstat (limited to 'Debian')
-rw-r--r--Debian/Debhelper/Buildsystem/autotools.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm2
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm2
6 files changed, 6 insertions, 6 deletions
diff --git a/Debian/Debhelper/Buildsystem/autotools.pm b/Debian/Debhelper/Buildsystem/autotools.pm
index edebd98d..3bbd2740 100644
--- a/Debian/Debhelper/Buildsystem/autotools.pm
+++ b/Debian/Debhelper/Buildsystem/autotools.pm
@@ -12,7 +12,7 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Buildsystem::makefile';
sub DESCRIPTION {
- "support for building GNU Autotools based packages"
+ "GNU Autotools (configure)"
}
sub check_auto_buildable {
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index fe91503c..8bdbabbb 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Buildsystem::makefile';
sub DESCRIPTION {
- "support for building CMake based packages (outside-source tree only)"
+ "CMake (CMakeLists.txt)"
}
sub check_auto_buildable {
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index db244526..244ef30d 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -43,7 +43,7 @@ sub make_first_existing_target {
}
sub DESCRIPTION {
- "support for building Makefile based packages (make && make install)"
+ "simple Makefile"
}
sub new {
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index e00a7eb0..ce69f4ce 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Buildsystem';
sub DESCRIPTION {
- "support for building Perl Build.PL based packages (in-source only)"
+ "Perl Module::Build (Build.PL)"
}
sub check_auto_buildable {
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 1d08dd66..eaaee537 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Buildsystem::makefile';
sub DESCRIPTION {
- "support for building Perl MakeMaker based packages (in-source only)"
+ "Perl ExtUtils::MakeMaker (Makefile.PL)"
}
sub check_auto_buildable {
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 1013c4bd..01a8c14e 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -12,7 +12,7 @@ use Debian::Debhelper::Dh_Lib;
use base 'Debian::Debhelper::Buildsystem';
sub DESCRIPTION {
- "support for building Python distutils based packages"
+ "Python distutils"
}
sub check_auto_buildable {