summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog25
-rw-r--r--debian/control6
2 files changed, 28 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 15109a6..4468a46 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+debhelper (3.0.9) unstable; urgency=low
+
+ * Modified to use dpkg-architecture instead of dpkg --print-architecture.
+ I hate this, and wish it wasn't necessary to make cross compiles for
+ the hurd work. Closes: #88494
+ * Now depends on debconf-utils for debconf-mergetemplates. Closes: #87321
+ * Continues to depend on lynx for html changelog conversions. Yes, these
+ and packages with translated debconf templates are rather rare, but
+ it makes more sense for debhelper to consistently depend on all utilities
+ it uses internally rather than force people to keep their dependancies
+ up to date with debhelper internals. If I decide tomorrow that w3m is
+ the better program to use to format html changelogs, I can make the
+ change and packages don't need to update their build dependancies.
+ Closes: #88464, #77743
+ * Test for init scripts before running them, since they are conffiles and
+ the admin may have removed them for some reason, and policy wants
+ us to deal with that gracefully.
+ * dh_makeshlibs: now uses objdump, should be more accurate. Closes:
+ #88426
+ * Wildcards have been supported for a while, Closes: #54197
+ * dh_installdocs and dh_link have been able to make doc-dir symlinks for
+ a while, Closes: #51225
+
+ -- Joey Hess <joeyh@debian.org> Sun, 4 Mar 2001 15:48:45 -0800
+
debhelper (3.0.8) unstable; urgency=low
* dh_perl update
diff --git a/debian/control b/debian/control
index 48ad49b..084fbb8 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1)
+Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils
Standards-Version: 3.5.2.0
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), lynx
-Suggests: dh-make, debconf-utils
+Depends: ${perl:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), lynx, debconf-utils, binutils
+Suggests: dh-make
Description: helper programs for debian/rules
A collection of programs that can be used in a debian/rules file to
automate common tasks related to building binary debian packages. Programs