summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/fixlinks2
-rwxr-xr-xdebian/rules17
3 files changed, 31 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 98089718..fc64c040 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+debhelper (2.0.89) unstable; urgency=low
+
+ * Patch from Jorgen `forcer' Schaefer <forcer at mindless.com> (much
+ modified)to make dh_installwm use new window manager registration method,
+ update-alternatives. Closes: #52156, #34684 (latter bug is obsolete)
+ * Fixed $dh{flavor} to be upper-case.
+ * Deprecated dh_installemavcsen --number; use --priority instead. Also,
+ the option parser requires the parameter be a number now. And,
+ dh_installwm now accepts --priority, and window manager packages should
+ start using it.
+ * dh_installwm now behaves like a proper debhelper command, and reads
+ debian/<package>.wm too. This is a small behavior change; filenames
+ specified on the command line no longer apply to all packages it acts
+ on. I can't belive this program existed for 2 years with such a glaring
+ problem; I guess most people don't need ot register 5 wm's in 3
+ sub-packages. Anyway, it can handle such things now. :-)
+ * Moved Dh_*.pm to /usr/lib/perl5/Debian/Debhelper. *big* change.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 2 Mar 2000 11:39:56 -0800
+
debhelper (2.0.88) unstable; urgency=low
* Copyright update: files in the examples directory are public domain.
@@ -1328,7 +1348,7 @@ debhelper (1.2.0) unstable; urgency=low
perl.. Since 1.1 has actually stabalized, I've upped this to 1.2.
* dh_md5sums: rewritten in perl, for large speed gain under some
circumstances (old version called perl sometimes, once per package.)
- * dh_installmenu, dh_installwmacsen, dh_installwm: perlized.
+ * dh_installmenu, dh_installemacsen, dh_installwm: perlized.
* Dh_Lib.pm: made autoscript() really work.
-- Joey Hess <joeyh@debian.org> Mon, 9 Nov 1998 13:04:16 -0800
diff --git a/debian/fixlinks b/debian/fixlinks
index f90bf4d9..23d4306a 100644
--- a/debian/fixlinks
+++ b/debian/fixlinks
@@ -1,8 +1,6 @@
#!/bin/sh -e
# Clean up after cvs's dreadful symlink handling, by making all the symlinks
# this package needs.
-ln -sf ../Dh_Lib.pm debian/Dh_Lib.pm
-ln -sf ../Dh_Getopt.pm debian/Dh_Getopt.pm
ln -sf postinst-menu autoscripts/postrm-menu
ln -sf postinst-modules autoscripts/postrm-modules
ln -sf postinst-mime autoscripts/postrm-mime
diff --git a/debian/rules b/debian/rules
index ccc0a363..da3305e5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,10 @@
#!/usr/bin/make -f
# Note that I have to refer to debhelper programs with ./, to make sure
-# I run the most current ones. That's also why there is a symlink to the
-# current Dh_lib.pm and the current Dh_getopt.pm in this debian/ directory.
+# I run the most current ones.
#
# This is _not_ a good example of a debhelper rules file, but I didn't need
-# to tell you that; just see the 25 lines of inlined perl below.. See
-# examples/ for some good examples.
+# to tell you that; just see the 25 lines of inlined perl below..
+# See examples/ for some good examples.
# If any automatic script generation is done in building this package,
# be sure to use the new templates from this package.
@@ -41,12 +40,15 @@ binary-indep: link-stamp build
./dh_testdir
./dh_testroot
./dh_clean -k
- ./dh_installdirs usr/bin usr/share/debhelper
+ ./dh_installdirs usr/bin usr/share/debhelper \
+ usr/lib/perl5/Debian/Debhelper
- echo -e "package Dh_Version;\n\$$version='$(VERSION)';" > debian/debhelper/usr/share/debhelper/Dh_Version.pm
+ echo -e "package Dh_Version;\n\$$version='$(VERSION)';" > \
+ debian/debhelper/usr/lib/perl5/Debian/Debhelper/Dh_Version.pm
find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
-exec install -p {} debian/debhelper/usr/bin \;
- cp -a Dh_*.pm debian/debhelper/usr/share/debhelper
+ cp -a Debian/Debhelper/*.pm \
+ debian/debhelper/usr/lib/perl5/Debian/Debhelper/
cp -a autoscripts debian/debhelper/usr/share/debhelper
rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
@@ -111,3 +113,4 @@ installhook:
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary dist
+