summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control13
-rw-r--r--debian/copyright5
-rwxr-xr-xdebian/rules42
4 files changed, 66 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..87d52639
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+debhelper (0.1) experimental; urgency=low
+
+ * First release. This is a snapshot of my work so far, and it not yet
+ ready to replace debstd.
+
+ -- Joey Hess <joeyh@master.debian.org> Mon, 22 Sep 1997 15:01:25 -0400
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..b934849f
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: debhelper
+Section: devel
+Priority: optional
+Maintainer: Joey Hess <joeyh@master.debian.org>
+Standards-Version: 2.1.1.0
+
+Package: debhelper
+Architecture: all
+Description: helper programs for debian/rules
+ A collection of programs that can be used in a debian/rules file to
+ automate common tasks. Programs are included to install various files into
+ your package, compress files, fix file permissions, integrate your package
+ with the debian menu system, etc.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..0feed1b2
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,5 @@
+Debhelper is written by Joey Hess <joeyh@master.debian.org>.
+Parts of the code came from debmake, by Christoph Lameter
+<clameter@debian.org>.
+
+The copyright of this package is GPL.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..0806a4db
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+# Note that I have to refer to debhelper programs witrh ./, to make sure
+# I run the most current ones.
+
+test_files=dh_lib
+
+build:
+ ./dh_testdir $(test_files)
+
+clean:
+ ./dh_testdir $(test_files)
+ ./dh_testroot
+ ./dh_clean
+
+# Build architecture-dependent files here.
+binary-arch: build
+ # We have nothing to do by default.
+
+# Build architecture-independent files here.
+binary-indep: build
+ ./dh_testdir $(test_files)
+ ./dh_testroot
+ ./dh_clean
+
+ install -d debian/tmp/usr/bin
+ find . -perm +111 -maxdepth 1 -type f \
+ -exec install -p {} debian/tmp/usr/bin \;
+ install -d debian/tmp/usr/lib/debhelper
+ cp dh_lib debian/tmp/usr/lib/debhelper
+
+ ./dh_installdocs TODO
+ ./dh_installexamples examples/*
+# ./dh_installmenu
+ ./dh_installmanpages
+ ./dh_installchangelogs
+ ./dh_compress
+ ./dh_installdebfiles
+ ./dh_fixperms
+ ./dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary