summaryrefslogtreecommitdiff
path: root/dh
diff options
context:
space:
mode:
Diffstat (limited to 'dh')
-rwxr-xr-xdh9
1 files changed, 4 insertions, 5 deletions
diff --git a/dh b/dh
index 498c7cff..8639ed07 100755
--- a/dh
+++ b/dh
@@ -443,6 +443,10 @@ sub run {
my @exclude=@{shift()};
my @options=@_;
+ # If some packages are excluded, add flags
+ # to prevent them from being acted on.
+ push @options, map { "-N$_" } @exclude;
+
# Check for override targets in debian/rules and
# run them instead of running the command directly.
my $override_command;
@@ -454,11 +458,6 @@ sub run {
$command="debian/rules";
@options="override_".$override_command;
}
- else {
- # If some packages are excluded, add flags
- # to prevent them from being acted on.
- push @options, map { "-N$_" } @exclude;
- }
# 3 space indent lines the command being run up under the
# sequence name after "dh ".