summaryrefslogtreecommitdiff
path: root/dh_auto_clean
diff options
context:
space:
mode:
Diffstat (limited to 'dh_auto_clean')
-rwxr-xr-xdh_auto_clean36
1 files changed, 13 insertions, 23 deletions
diff --git a/dh_auto_clean b/dh_auto_clean
index 625675b8..1b7d46cd 100755
--- a/dh_auto_clean
+++ b/dh_auto_clean
@@ -2,7 +2,7 @@
=head1 NAME
-dh_auto_clean - clean temporary files after building package sources
+dh_auto_clean - automatically cleans up after a build
=cut
@@ -11,21 +11,19 @@ use Debian::Debhelper::Dh_Buildsystems;
=head1 SYNOPSIS
-B<dh_auto_clean> [S<I<debhelper options>>] [S<I<dh_auto options>>] [S<B<--> I<params>>]
+B<dh_auto_clean> [S<I<debhelper options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
-dh_auto_clean is a debhelper program that is responsible for the I<clean> step
-of the L<dh_auto(7)> building process. It tries to automatically clean up after
-a package build by removing all temporary files from the build directory or
-even the build directory itself as appropriate. dh_auto_clean will fail only if
-the source build system clean routine fails. However, if the latter does not
-exist or there is nothing to clean it will exit with zero status doing nothing.
+dh_auto_clean is a debhelper program that tries to automatically clean up
+after a package build. If there's a Makefile and it contains a "distclean",
+"realclean", or "clean" target, then this is done by running make (or MAKE,
+if the environment variable is set). If there is a setup.py or Build.PL, it
+is run to clean the package.
-If dh_auto_clean does not meet your needs or does not work, it is safe to
-skip/override it entirely and just run clean up manually.
-
-#DH_AUTO SHARED OPTIONS#
+This is intended to work for about 90% of packages. If it doesn't work, or
+tries to use the wrong clean target, you're encouraged to skip using
+dh_auto_clean at all, and just run make clean manually.
=head1 OPTIONS
@@ -38,11 +36,6 @@ or override the any standard parameters that dh_auto_clean passes.
=back
-=head1 SUPPORTED BUILD SYSTEMS
-
-#SUPPORTED BUILD SYSTEMS INTRO#
-#SUPPORTED BUILD SYSTEMS LIST#
-
=cut
buildsystems_init();
@@ -50,15 +43,12 @@ buildsystems_do();
=head1 SEE ALSO
-L<dh_auto(7)>
-
L<debhelper(7)>
-This program is a part of debhelper and its dh_auto package source building suite.
+This program is a part of debhelper.
-=head1 AUTHORS
+=head1 AUTHOR
- Joey Hess <joeyh@debian.org>
- Modestas Vainius <modestas@vainius.eu>
+Joey Hess <joeyh@debian.org>
=cut