summaryrefslogtreecommitdiff
path: root/dh_auto_configure
diff options
context:
space:
mode:
Diffstat (limited to 'dh_auto_configure')
-rwxr-xr-xdh_auto_configure23
1 files changed, 0 insertions, 23 deletions
diff --git a/dh_auto_configure b/dh_auto_configure
index 41f6210f..0445c343 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -40,29 +40,6 @@ or override the standard parameters that dh_auto_configure passes.
init();
-sub dpkg_architecture_value {
- my $var=shift;
- my $value=`dpkg-architecture -q$var 2>/dev/null` || error("dpkg-architecture failed");
- chomp $value;
- return $value;
-}
-
-sub sourcepackage {
- open (CONTROL, 'debian/control') ||
- error("cannot read debian/control: $!\n");
- while (<CONTROL>) {
- chomp;
- s/\s+$//;
- if (/^Source:\s*(.*)/) {
- close CONTROL;
- return $1;
- }
- }
-
- close CONTROL;
- error("could not find Source: line in control file.");
-}
-
if (-x "configure") {
# Standard set of options for configure.
my @opts;