summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install32
1 files changed, 16 insertions, 16 deletions
diff --git a/dh_auto_install b/dh_auto_install
index a5d483b1..ccb1143f 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -18,31 +18,31 @@ B<dh_auto_install> [S<I<build system options>>] [S<I<debhelper options>>] [S<B<-
=head1 DESCRIPTION
-dh_auto_install is a debhelper program that tries to automatically install
+B<dh_auto_install> is a debhelper program that tries to automatically install
built files. It does so by running the appropriate command for the build
-system it detects the package uses. For example, if there's a Makefile and
-it contains a "install" target, then this is done by running make (or MAKE,
-if the environment variable is set). If there is a setup.py or Build.PL,
+system it detects the package uses. For example, if there's a F<Makefile> and
+it contains a B<install> target, then this is done by running B<make> (or B<MAKE>,
+if the environment variable is set). If there is a F<setup.py> or F<Build.PL>,
it is used. Note that the Ant build system does not support installation,
-so dh_auto_install will not install files built using Ant.
+so B<dh_auto_install> will not install files built using Ant.
-Unless --destdir option is specified, the files are installed into
-debian/<package>/ if there is only one binary package. In the multiple binary
-package case, the files are instead installed into debian/tmp/, and should be
+Unless B<--destdir> option is specified, the files are installed into
+debian/I<package>/ if there is only one binary package. In the multiple binary
+package case, the files are instead installed into F<debian/tmp/>, and should be
moved from there to the appropriate package build directory using
L<dh_install(1)>.
-DESTDIR is used to tell make where to install the files.
-If the Makefile was generated by MakeMaker from a Makefile.PL, it will
-automatically set PREFIX=/usr too, since such Makefiles need that.
+B<DESTDIR> is used to tell make where to install the files.
+If the Makefile was generated by MakeMaker from a F<Makefile.PL>, it will
+automatically set B<PREFIX=/usr> too, since such Makefiles need that.
This is intended to work for about 90% of packages. If it doesn't work, or
tries to use the wrong install target, you're encouraged to skip using
-dh_auto_install at all, and just run make install manually.
+B<dh_auto_install> at all, and just run make install manually.
=head1 OPTIONS
-See L<debhelper(7)/BUILD SYSTEM OPTIONS> for a list of common build
+See L<debhelper(7)/B<BUILD SYSTEM OPTIONS>> for a list of common build
system selection and control options.
=over 4
@@ -51,12 +51,12 @@ system selection and control options.
Install files into the specified I<directory>. If this option is not specified,
destination directory is determined automatically as described in the
-L</DESCRIPTION> section.
+L</B<DESCRIPTION>> section.
=item B<--> I<params>
-Pass "params" to the program that is run. These can be used to supplement
-or override the any standard parameters that dh_auto_install passes.
+Pass I<params> to the program that is run. These can be used to supplement
+or override the any standard parameters that B<dh_auto_install> passes.
=back