summaryrefslogtreecommitdiff
path: root/dh_auto_install
diff options
context:
space:
mode:
Diffstat (limited to 'dh_auto_install')
-rwxr-xr-xdh_auto_install37
1 files changed, 15 insertions, 22 deletions
diff --git a/dh_auto_install b/dh_auto_install
index 5c772245..db2c6e90 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -2,7 +2,7 @@
=head1 NAME
-dh_auto_install - install built files into the temporary directory under debian/
+dh_auto_install - automatically runs make install or similar
=cut
@@ -13,15 +13,14 @@ use Cwd;
=head1 SYNOPSIS
-B<dh_auto_install> [S<I<debhelper options>>] [S<I<dh_auto options>>] [S<B<--> I<params>>]
+B<dh_auto_install> [S<I<debhelper options>>] [S<B<--> I<params>>]
=head1 DESCRIPTION
-dh_auto_install is a debhelper program that is responsible for the I<install>
-step of the L<dh_auto(7)> building process. dh_auto_install tries to run
-original package installation routine to install built files into the proper
-places of the file system hierarchy recreated under the (temporary) directory
-in debian/.
+dh_auto_install is a debhelper program that tries to automatically install
+built files. If there's a Makefile and it contains a "install" target,
+then this is done by running make (or MAKE, if the environment variable is
+set). If there is a setup.py or Build.PL, it is used.
The files are installed into debian/<package>/ if there is only one binary
package. In the multiple binary package case, the files are instead
@@ -29,10 +28,13 @@ installed into debian/tmp/, and should be moved from there to the
appropriate package build directory using L<dh_install(1)> or
L<dh_movefiles(1)>.
-If dh_auto_install does not meet your needs or does not work, it is safe to
-skip/override it entirely and just run C<make install> or the like manually.
+DESTDIR is used to tell make where to install the files.
+If the Makefile was generated by MakeMaker from a Makefile.PL, it will
+automatically set PREFIX=/usr too, since such Makefiles need that.
-#DH_AUTO SHARED OPTIONS#
+This is intended to work for about 90% of packages. If it doesn't work, or
+tries to use the wrong install target, you're encouraged to skip using
+dh_auto_install at all, and just run make install manually.
=head1 OPTIONS
@@ -45,11 +47,6 @@ or override the any standard parameters that dh_auto_install passes.
=back
-=head1 SUPPORTED BUILD SYSTEMS
-
-#SUPPORTED BUILD SYSTEMS INTRO#
-#SUPPORTED BUILD SYSTEMS LIST#
-
=cut
buildsystems_init();
@@ -68,16 +65,12 @@ buildsystems_do("install", $destdir);
=head1 SEE ALSO
-L<dh_auto(7)>
-
L<debhelper(7)>
-This program is a part of debhelper and its dh_auto package source building
-suite.
+This program is a part of debhelper.
-=head1 AUTHORS
+=head1 AUTHOR
- Joey Hess <joeyh@debian.org>
- Modestas Vainius <modestas@vainius.eu>
+Joey Hess <joeyh@debian.org>
=cut