summaryrefslogtreecommitdiff
path: root/dh_clean
diff options
context:
space:
mode:
Diffstat (limited to 'dh_clean')
-rwxr-xr-xdh_clean68
1 files changed, 65 insertions, 3 deletions
diff --git a/dh_clean b/dh_clean
index fb4e3a88..7876cddb 100755
--- a/dh_clean
+++ b/dh_clean
@@ -1,10 +1,61 @@
#!/usr/bin/perl -w
-#
-# Clean up $tmp and other tepmorary files generated by the
-# build process.
+
+=head1 NAME
+
+dh_clean - clean up package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_clean [debhelper options] [-k] [-d] [file ...] [-Xitem]
+
+=head1 DESCRIPTION
+
+dh_clean is a debhelper program that is responsible for cleaning up after a
+package is built. It removes the package build directories, and removes
+some
+other files, such as debian/substvars, debian/files, and any detritus left
+behind by other debhelper commands. It also removes common files that
+should not appear in a debian diff:
+ #*# *~ DEADJOE *.orig *.rej *.SUMS TAGS core .deps/* *.P
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-k>, B<--keep>
+
+Do not delete debian/files. When do you want to use this? Anytime you have a
+debian/rules that has 2 binary targets that build different .deb packages;
+for example, one target is binary-arch, and the other is binary-indep, or
+one target builds the shared library, and the other the -dev package. If you
+didn't use -k in these cases, then debian/files would be deleted in the
+middle, and your changes file will only contain the last binary package that
+was built.
+
+=item B<-d>, B<--dirs-only>
+
+Only clean the package build directories, do not clean up any other files
+at all.
+
+=item B<-X>I<item> B<--exclude=>I<item>
+
+Exclude files that contain "item" anywhere in their filename from being
+deleted, even if they would normally be deleted. You may use this option
+multiple times to build up a list of things to exclude.
+
+=item I<file ...>
+
+Delete these files too.
+
+=back
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -51,3 +102,14 @@ if (! $dh{D_FLAG}) {
doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1);
+=head1 SEE ALSO
+
+L<debhelper(1)|debhelper>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut