summaryrefslogtreecommitdiff
path: root/dh_clean
diff options
context:
space:
mode:
Diffstat (limited to 'dh_clean')
-rwxr-xr-xdh_clean20
1 files changed, 10 insertions, 10 deletions
diff --git a/dh_clean b/dh_clean
index 2fca7815..dc29e36f 100755
--- a/dh_clean
+++ b/dh_clean
@@ -11,28 +11,28 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] [S<I<file ...>>]
+B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] [S<I<file> ...>]
=head1 DESCRIPTION
-dh_clean is a debhelper program that is responsible for cleaning up after a
+B<dh_clean> is a debhelper program that is responsible for cleaning up after a
package is built. It removes the package build directories, and removes some
-other files including debian/files, and any detritus left behind by other
+other files including F<debian/files>, and any detritus left behind by other
debhelper commands. It also removes common files that should not appear in a
-debian diff:
+Debian diff:
#*# *~ DEADJOE *.orig *.rej *.SUMS TAGS .deps/* *.P *-stamp
It does not run "make clean" to clean up after the build process. Use
L<dh_auto_clean(1)> to do things like that.
-dh_clean (or "dh clean") should be the last debhelper command run in the
-clean target in debian/rules.
+B<dh_clean> (or "B<dh clean>") should be the last debhelper command run in the
+B<clean> target in F<debian/rules>.
=head1 FILES
=over 4
-=item debian/clean
+=item F<debian/clean>
Can list other files to be removed.
@@ -53,13 +53,13 @@ at all.
=item B<-X>I<item> B<--exclude=>I<item>
-Exclude files that contain "item" anywhere in their filename from being
+Exclude files that contain I<item> anywhere in their filename from being
deleted, even if they would normally be deleted. You may use this option
multiple times to build up a list of things to exclude.
-=item I<file ...>
+=item I<file> ...
-Delete these files too.
+Delete these I<file>s too.
=back