summaryrefslogtreecommitdiff
path: root/dh_testdir
diff options
context:
space:
mode:
Diffstat (limited to 'dh_testdir')
-rwxr-xr-xdh_testdir15
1 files changed, 12 insertions, 3 deletions
diff --git a/dh_testdir b/dh_testdir
index d7e945b9..db7f7cef 100755
--- a/dh_testdir
+++ b/dh_testdir
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!/usr/bin/perl
=head1 NAME
@@ -7,8 +7,11 @@ dh_testdir - test directory before building Debian package
=cut
use strict;
+use warnings;
use Debian::Debhelper::Dh_Lib;
+our $VERSION = DH_BUILTIN_VERSION;
+
=head1 SYNOPSIS
B<dh_testdir> [S<I<debhelper options>>] [S<I<file> ...>]
@@ -32,12 +35,18 @@ Test for the existence of these files too.
=cut
+# This command is completely useless when called from dh(1) as dh will
+# have attempted to read d/control before it even constructs the
+# command sequences. Accordingly, there is no doubt that the
+# following is unconditionally true:
+#
+# PROMISE: DH NOOP
+
# Run before init because init will try to read debian/control and
# we want a nicer error message.
checkfile('debian/control');
-init();
-inhibit_log();
+init(inhibit_log => 1);
foreach my $file (@ARGV) {
checkfile($file);