summaryrefslogtreecommitdiff
path: root/dh_testdir
diff options
context:
space:
mode:
Diffstat (limited to 'dh_testdir')
-rwxr-xr-xdh_testdir16
1 files changed, 8 insertions, 8 deletions
diff --git a/dh_testdir b/dh_testdir
index 4d3c700b..8bd960d3 100755
--- a/dh_testdir
+++ b/dh_testdir
@@ -1,14 +1,14 @@
-#!/bin/sh -e
+#!/usr/bin/perl -w
#
# Checks to make sure we are building the package in the right directory.
# Tests for the existance of debian/control, and for the existance
# of any other files you specify on the command line.
-PATH=debian:$PATH:/usr/lib/debhelper
-source dh_lib
+use Debian::Debhelper::Dh_Lib;
+init();
-for file in debian/control $@; do
- if [ ! -e "$file" ] ; then
- error "\"$file\" not found. Are you sure you are in the correct directory?"
- fi
-done
+foreach $file ('debian/control',@ARGV) {
+ if (! -e $file) {
+ error("\"$file\" not found. Are you sure you are in the correct directory?");
+ }
+}