summaryrefslogtreecommitdiff
path: root/examples/rules
diff options
context:
space:
mode:
Diffstat (limited to 'examples/rules')
-rwxr-xr-xexamples/rules41
1 files changed, 41 insertions, 0 deletions
diff --git a/examples/rules b/examples/rules
new file mode 100755
index 00000000..e6ebf0b0
--- /dev/null
+++ b/examples/rules
@@ -0,0 +1,41 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ # Add here commands to compile the pacckage.
+ #$(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_cleantmp
+ # Add here commands to clean up after the build process.
+ #-$(MAKE) distclean
+ rm -f build-stamp
+
+# Build architecture-independent files here.
+binary-indep: build
+ # We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build
+ dh_testdir
+ dh_testroot
+ dh_cleantmp
+ # Add here commands to install the files into debian/tmp
+ #$(MAKE) PREFIX=debian/tmp install
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+ dh_installmanpages
+ dh_installchangelogs
+ dh_compress
+ dh_installdebfiles
+ dh_fixperms
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary