summaryrefslogtreecommitdiff
path: root/debian/changelog
Commit message (Collapse)AuthorAge
* Spanish translation update. Closes: #636245 Thanks, Omar CampagneJoey Hess2011-12-08
|
* dh_strip: Use build-id in /usr/lib/debug. Closes: #642158 Thanks, Jakub WilkJoey Hess2011-12-08
| | | | I see no reason to make this v9 only.
* Pass CPPFLAGS to qmake. Closes: #646129 Thanks, Felix GeyertJoey Hess2011-12-08
|
* releasing version 8.9.12Joey Hess2011-12-07
|
* executable config files. bleh, arghJoey Hess2011-12-07
| | | | | | | | | | | | | | | | | | Debhelper config files may be made executable programs that output the desired configuration. No further changes are planned to the config file format; those needing powerful syntaxes may now use a programming language of their choice. In many bugs I see a tendency of users wanting debhelper configuration files to have their pet feature from some programming language. So I choose to short-circuit this process by taking it to its logical conclusion, and without the bother of developing a new language myself. [ Is this consistent with my boycott/disinterest in integrating features features first developed in Ubuntu? Yes. Instead of blocking the issue of multiarch needing variable expansions, I have stepped back and let anyone make whatever mess they desire while not forcing that mess on the rest of us. ]
* add and enable German translationJoey Hess2011-12-06
|
* Typo fixes. Closes: #651224 Thanks, Chris LeickJoey Hess2011-12-06
|
* releasing version 8.9.11Joey Hess2011-11-17
|
* Fix broken option passing to objcopy. Closes: #649044Joey Hess2011-11-17
|
* releasing version 8.9.10Joey Hess2011-11-16
|
* dh: Ensure -a and -i are passed when running override_dh_command-arch and ↵Joey Hess2011-11-16
| | | | override_dh_command-indep targets. This is needed when the binary target is run, rather than binary-arch/binary-indep. Closes: #648901
* dh_strip: In v9, pass --compress-debug-sections to objcopy. Needs a new ↵Joey Hess2011-11-07
| | | | enough binutils and gdb; debhelper backport may need to disable this. Thanks, Aurelien Jarno and Bastien ROUCARIES. Closes: #631985
* releasing version 8.9.9Joey Hess2011-11-04
|
* dh: Add dh_auto_configure parameter example. Closes: #645335Joey Hess2011-10-14
|
* changelogJoey Hess2011-10-06
|
* updateJoey Hess2011-09-30
|
* perl_makemaker: In v9, pass CFLAGS to Makefile.PL using OPTIMIZE. Closes: ↵Joey Hess2011-09-29
| | | | #643702 Thanks, Steve Langasek.
* setting OPTIMIZE could in theory lead to breakage, so make it v9Joey Hess2011-09-29
|
* Mention in debhelper(7) that buildsystem options are typically passed to dh. ↵Joey Hess2011-09-26
| | | | Closes: #643069
* Clarify description of dh_auto_* -- params. Closes: #642786Joey Hess2011-09-25
|
* dh: Avoid compat deprecation warning before option parsing. Closes: #641361Joey Hess2011-09-12
|
* dh_fixperms: Operate on .ali files throughout /usr/lib, including multiarch ↵Joey Hess2011-09-12
| | | | | | | dirs. Closes: #641279 This is extra work, but querying dpkg-architecture for the multiarch lib dir could easily take just as long.
* releasing version 8.9.7Joey Hess2011-09-11
|
* dh: Avoid running install sequence a third time in v9 when the rules file ↵Joey Hess2011-09-11
| | | | | | has explicit binary-indep and binary-arch targets. Closes: #639341 Thanks, Yann Dirson for test case.
* -arch and -indep overridesJoey Hess2011-09-11
| | | | | | | | | | | | | | | | | * dh: Now you can use override_dh_command-arch and override_dh_command-indep to run different overrides when building arch and indep packages. This allows for a much simplified form of rules file in this situation, where build-arch/indep and binary-arch/indep targets do not need to be manually specified. See man page for examples. * dh: Note that if a rules file has say, override_dh_fixperms-arch, but no corresponding override_dh_fixperms-indep, then the unoverridden dh_fixperms will be run on the indep packages. * dh: Note that the old override_dh_command takes precidence over the new overrides, because mixing the two types of overrides would have been too complicated. In particular, it's difficult to ensure an old override target will work if it's sometimes constrained to only acting on half the packages it would normally run on. This would be a source of subtle bugs, so is avoided.
* Tighten parsing of DEB_BUILD_OPTIONS.Joey Hess2011-09-09
| | | | | A future nostripexceptonfullmoon option seems unlikely, but sure, let's be strict. More importantly, let's reuse good code.
* Avoid writing debhelper log files in no-act mode. Closes: #640586Joey Hess2011-09-05
|
* typoJoey Hess2011-09-05
|
* Remove obsolete versioned dependency on perl-base.Joey Hess2011-08-29
| | | | | | 5.10 is in stable, which is good enough for me. (And this dependency was added for very unclear reasons in the first place.)
* remove build-dep on fileJoey Hess2011-08-29
| | | | | It was only needed so dh_shlibdeps and dh_strip, which are no longer run during build.
* adh: Don't bother running dh_shlibdebs, dh_makeshelibs, or dh_strip for the ↵Joey Hess2011-08-29
| | | | | | | binary target when all packages being acted on are indep. This is a not particularly interesting optimisation, but it will allow my next commit..
* debhelper no longer build-depends on man-db, to ease bootstrapping.Joey Hess2011-08-29
| | | | The man page recode is not necessary as the man pages are utf-8 already.
* releasing version 8.9.6Joey Hess2011-08-23
|
* releasing version 8.9.5Joey Hess2011-08-23
|
* dh_compress: Don't compress _sources documentation subdirectory as used by ↵Joey Hess2011-08-20
| | | | python-sphinx. Closes: #637492 Thanks, Jakub Wilk
* dpkg-buildflags is only used to set environment in v9Joey Hess2011-08-06
| | | | | | To avoid re-breaking packages that were already broken a first time by dpkg-buildpackage unconditionally setting the environment, and unbroke it by unsetting variables in the rules file. (Example: numpy)
* changelogJoey Hess2011-08-05
|
* changelogJoey Hess2011-08-05
|
* dh: The --before --after --until and --remaining options are deprecated. Use ↵Joey Hess2011-08-05
| | | | override targets instead.
* releasing version 8.9.3Joey Hess2011-07-19
|
* dh: Remove obsolete optimisation hack that caused sequence breakage in v9 ↵Joey Hess2011-07-19
| | | | | | | | | | | | | | | | | | with a rules file with an explict build target. Closes: #634784 This hack was necessary back when dh ran each target, and so recursively invoked itself. If debian/rules binary ran debian/rules binary-arch ran debian/rules install-arch ran debian/rules build-arch, then debhelper commands would be running with -a throughout, and so for debian/rules binary-indep it would have to re-run all the commands with -i. The hack avoided this extra work (and expecially dh_auto_configure running twice) by first running the common commands without -i or -a and only then following through with running the explicit per-arch targets, which didn't run many (if any) additional commands. But now dh does not run implicit targets, so (unless targets are explicit), it will instead just construct a sequence of debhelper commands to run directly, and so the -a flag is avoided.
* releasing version 8.9.2Joey Hess2011-07-18
|
* Support make 3.82. Closes: #634385Joey Hess2011-07-18
|
* releasing version 8.9.1Joey Hess2011-07-17
|
* changelogJoey Hess2011-07-17
|
* Remove debhelper.log in compat level 1. Closes: #634155Joey Hess2011-07-17
|
* Now the QT4 version of qmake can be explicitly selected by passing ↵Joey Hess2011-07-16
| | | | | | | | | | | | --buildsystem=qmake_qt4. Closes: #566840 There is that build system option patch that I suckily never applied, and could be used here.. but this is at its core a different build system, and so handling it as such makes the most sense. It may make sense to have a qmake_qt3 build system, but perhaps QT 3 will instead just go away. I considered just waiting, but this is an easy fix. ;)
* add bug closureJoey Hess2011-07-16
|
* dh: In v9, do not enable any python support commands.Joey Hess2011-07-16
| | | | | | | | | | | | dh_pysupport has started emitting a deprecation warning, which is very annoying since it clutters every build that uses dh -- even builds where it doesn't do anything. Since there is not just a dh_python2, but also a dh_python3 waiting in the wings, this is clearly too volatile a situation for dh to try to support further. I considered making dh_python detect and run the right dh_python[23] helper -- a python helper helper as it were -- but 70-odd packages still use that command.
* Typo fixes. Closes: #632662Joey Hess2011-07-04
|