summaryrefslogtreecommitdiff
path: root/debian
Commit message (Collapse)AuthorAge
* r1965: * dh_fixperms: Change a chmod +x to chmod a+x, to avoid the umaskjoeyh2006-12-26
| | | | influencing it.
* r1964: whitespacejoeyh2006-12-08
|
* r1963: * Typo. Closes: #400571joeyh2006-11-27
|
* r1962: Correct typo into french manpagesvperrin-guest2006-11-19
|
* r1960: releasing version 5.0.42joeyh2006-11-12
|
* r1959: Update french translation with recents changes in dh_link and ↵vperrin-guest2006-11-07
| | | | dh_installinfo
* r1957: releasing version 5.0.41joeyh2006-11-07
|
* r1956: * Correct some incorrect instances of "v4 only" in docs. Closes: #381536joeyh2006-11-07
| | | | | | * dh_installinfo: Put the section madness to bed by not passing any section information to install-info. Current install-info parses INFO-DIR-SECTION on its own if that's not specified. Closes: #337215
* r1955: * Tighten python-support and python-central dependencies of debhelper,joeyh2006-10-27
| | | | | in an IMHO rather futile attempt to deal with derived distributions. Closes: #395495
* r1953: Encoding french translation from charset ISO-8859-1 to UTF-8vperrin-guest2006-10-15
|
* r1952: Update french translation with recent change in dh_installchangelogsvperrin-guest2006-10-15
|
* r1951: * dh_installchangelogs man page typo. Closes: #393155joeyh2006-10-15
|
* r1949: releasing version 5.0.40joeyh2006-10-06
|
* r1948: * Update french translation with recent change in dh_pythonvperrin-guest2006-10-04
|
* r1947: updatejoeyh2006-10-04
|
* r1946: * dh_python: Also be a no-op if there's a Python-Version control file ↵joeyh2006-10-03
| | | | field.
* r1945: * Conflict with python-support <= 0.5.2 and python-central <= 0.5.4.joeyh2006-10-01
|
* r1944: forgot thisjoeyh2006-10-01
|
* r1942: lines (excluding POD). This is not a joke, and 100 lines would be ↵joeyh2006-10-01
| | | | | | better. * Add size test exception for dh_python, since it's deprecated.
* r1941: * ACK last three NMUs with thanks to Raphael Hertzog for making the ↵joeyh2006-10-01
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | best of a difficult situation. * Revert all dh_python changes. Closes: #381389, #378604 * Conflict with python-support << 0.5.3 and python-central << 0.5.5. * Make dh_python do nothing if debian/pycompat is found. The new versions of dh_pysupport or dh_pycentral will take care of everything dh_python used to do in this situation. * dh_python is now deprecated. Closes: #358392, #253582, #189474 * Non-maintainer upload. * Update of dh_python - when buidling for a non-standard Python version, generate more reasonable Depends like "python (>= X.Y) | pythonX.Y" Closes: #375576 - fix handling of private extensions. Closes: #375948 - fix parsing of XS-Python-Version, it didn't work if only fixed versions were listed in XS-Python-Version. - fix use of unitialized value. Closes: #374776 - fix typos in POD documentation. Closes: #375936 * Non-maintainer upload. * Update of dh_python - vastly refactored, easier to understand, and the difference between old policy and new policy is easier to grasp - it supports an -X option which can be used to not scan some files - uses debian/pyversions as reference source of information for dependencies but also parse the XS-Python-Version header as fallback. - ${python:Versions}'s default value is XS-Python-Version's value instead of "all" when the package doesn't depend on a specific python version. Closes: #373853 - always generate ${python:Provides} and leave the responsibility to the maintainer to not use ${python:Provides} if he doesn't want the provides. - uses debian/pycompat or DH_PYCOMPAT as reference field to run in new policy mode. The presence of XS-Python-Version will also trigger the new policy mode (this is for short-term compatibility, it may be removed in the not too-distant future). DH_PYCOMPAT=1 is the default mode and is compatible to the old policy. DH_PYCOMPAT=2 is the new mode and is compatible with the new policy. * Use "grep ^Version:" instead of "grep Version:" on the output of dpkg-parsechangelog since the above changelog entry matched "Version:" and thus made the build fail. * Non-maintainer upload. * Integrate the new dh_python implementing the new Python policy. Closes: #370833
* r1940: add svn fieldjoeyh2006-09-22
|
* r1939: * Add size test, which fails on any debhelper program of more than 150joeyh2006-07-29
| | | | lines. This is not a joke, and 100 lines would be better.
* r1936: joeyh2006-07-02
| | | | * move po4a to Build-Depends as it's run in clean.
* r1935: * Update french translation with recent change in dh_installmodulesvperrin-guest2006-06-27
|
* r1934: nmu notejoeyh2006-06-13
|
* r1932: split the scripts for the two cases, undo behavior changejoeyh2006-06-12
|
* r1931: * dh_installxfonts: In postrm, run the deregistraton code even on ↵joeyh2006-06-12
| | | | | | | upgrade, in case an upgrade involves moving fonts around (or removing or renaming fonts). Closes: #372686
* r1929: * dh_installmodules: depmod -a is no longer run during boot, so if a ↵joeyh2006-06-09
| | | | | | | | | | | | | | module package is installed for a kernel other than the running kernel, just running depmod -a in the postinst is no longer sufficient. Instead, run depmod -a -F /boot/System.map-<kvers> <kvers> The kernel version is guessed at based on the path to the modules in the package. Closes: #301424 * Note: behavior change due to the above: The mere existence of a debian/package.modules file will no longer make dh_installmodules add code to maintainer scripts. * Untested.
* r1926: releasing version 5.0.36joeyh2006-06-09
|
* r1924: * Patch from Guillem Jover to make --same-arch handling code supportjoeyh2006-06-07
| | | | | | | the new form of architecture wildcarding which allows use of things like "linux-any" and "any-i386" in the Architecture field. Note that you'll need to build-depend on a new enough dpkg-dev if using this support. Closes: #371082
* r1922: * Remove old alternate dependency on fileutils. Closes: #370011joeyh2006-06-03
|
* r1921: fixjoeyh2006-06-03
|
* r1920: * Update french translation with recent change in dh_installxfontsvperrin-guest2006-05-11
|
* r1918: releasing version 5.0.35joeyh2006-05-11
|
* r1917: * dh_installman: When --language is used, be smarter about strippingjoeyh2006-05-11
| | | | | | * dh_installxfonts: /etc/X11/fonts/X11R7 is deprecated, back to looking in old location, and not passing --x11r7-layout to update-fonts-alias and update-fonts-scale (but still to update-fonts-dir). Closes: #366234
* r1916: * dh_installman: When --language is used, be smarter about stripping joeyh2006-05-11
| | | | | language codes from man page filenames. Only strip things that look like codes that match the specified languages. Closes: #366645
* r1914: * dh_installcatalogs: Make sure that /etc/sgml exists. Closes: #364946joeyh2006-04-27
|
* r1912: releasing version 5.0.33joeyh2006-04-24
|
* r1911: * dh_installxfonts: Patch from Theppitak Karoonboonyanan to fixjoeyh2006-04-24
| | | | an instance of /etc/X11/fonts/ that was missed before. Closes: #364530
* r1910: * Update french translation with recent change in dh_installxfontsvperrin-guest2006-04-21
|
* r1908: * dh_installudev: Include rules.d directory so symlink can be made evenjoeyh2006-04-18
| | | | before udev is installed. Closes: #363307
* r1906: releasing version 5.0.31joeyh2006-04-17
|
* r1905: * dh_installxfonts: pass --x11r7-layout to update-fonts-* commands to ↵joeyh2006-04-17
| | | | | | | | | | | | ensure they use the right new directory. Closes: #362820 * dh_installxfonts: also, alias files have moved from /etc/X11/fonts/* to /etc/X11/fonts/X11R7/*, update call to update-fonts-alias and the man page accordingly; packages containing alias files will need to switch to the new directory on their own. * dh_installudev: correct documentation for --name. Closes: #363028 * Fix broken directory removal code.
* r1904: * Update french translation with recents changes in ↵vperrin-guest2006-04-14
| | | | | | | | dh_installxfonts, dh_link and dh_compress manpages * Delete -f option in po4a command line. Bug in po4a has been corrected in new version (0.24.1). * Change build-depends for po4a. New version (0.24.1). * Add code for removing empty "lang" directories into man/ when cleaning.
* r1902: releasing version 5.0.30joeyh2006-04-13
|
* r1900: * dh_installxfonts: Random hack to deal with X font dirs moving tojoeyh2006-04-13
| | | | | | | | /usr/share/fonts/X11/ -- look there for fonts as well as in the old location, although the old location probably won't be seen by X anymore. * dh_installxfonts: Generate misc:Depends on new xfonts-utils. * dh_compress: compress pcm fonts under usr/share/fonts/X11/ * dh_link: change example that used X11R6 directory.
* r1897: * dh_makeshlibs: Fix udeb package name regexp. Closes: #361677joeyh2006-04-09
|
* r1895: releasing version 5.0.27joeyh2006-03-30
|
* r1894: * dh_installman: die with an error if a man page read for so lines failsjoeyh2006-03-29
| | | | Closes: #359020
* r1893: * Update pot file and french translation with recent changes in ↵vperrin-guest2006-03-28
| | | | dh_installdirs and dh_movefiles manpages.