summaryrefslogtreecommitdiff
path: root/doc/TODO
blob: b04a647b412ea3e68a9d565369c47e0899e67e8a (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
v8:

* escaping in config files (for whitespace)?
* make dh_install use hard links for efficiency (maybe?)
* dh_installinit --restart-after-upgrade as default?
* clean up dh's handling of options passed onto commands it calls,
  by implementing one of the changes discussed in #570039
  (either change #3, change #4, or change #5; change #0 was done, but 
  was an incomplete workaround)
  My preference ATM is #3, require dh options come before --,
  and after, options to be passed on to commands.
* better package arch filtering for -N , -p (#576990)
* Support DEB_BUILD_OPTIONS=debug ; maybe also support passing
  -g -O2 by default. See patch (and discussion of why this breaks
  compatability) in #544844.

Deprecated:

* DH_COMPAT 1, 2, 3, 4. Can be removed once all packages are seen to be using
  a newer version. I won't hold my breath. Now with evil warning messages
  though.
* dh_suidregister. Once nothing in the archive uses it.
* dh_installmanpages.
* dh_movefiles. I won't hold my breath. Have not added deprecation
  docs or message yet.
* dh_undocumented
* dh_installinit --init-script (make it warn)
* dh_python
* dh_clean -k
* dh_desktop, dh_scrollkeeper. Remove eventually..
* -s flag, not formally deprecated yet; remove eventually
* -u flag; add a warning on use and remove eventually
* delsubstvar() and the last parameter to addsubstvar that makes it remove
  a string are not used in debhelper itself, but have been left in the
  library in case other things use them. Deprecate and remove.
* dh --before , --after , --until , --remaining (not formally deprecated yet)
* debian/compress files

Also, grep the entire archive for all dh_* command lines,
and check to see what other switches are not being used, and maybe remove
some of them.