summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deb-view.el4
-rw-r--r--debian/changelog5
2 files changed, 6 insertions, 3 deletions
diff --git a/deb-view.el b/deb-view.el
index 2cd2830..10ad339 100644
--- a/deb-view.el
+++ b/deb-view.el
@@ -641,7 +641,9 @@ If the file is from the INFO buffer, then open in the other (larger) window."
("\\.Z$" . deb-view-tar-uncompress-while-visiting)
) auto-mode-alist)))
(if (string-match "INFO$" buffer-file-name)
- (tar-extract-other-window)
+ (progn
+ (tar-extract-other-window)
+ (view-buffer (current-buffer) 'kill-buffer-if-not-modified))
(tar-extract 'view))))
(defun deb-view-tar-w3 ()
diff --git a/debian/changelog b/debian/changelog
index 0fcec21..c03c4a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
-debian-el (37.8) UNRELEASED; urgency=medium
+debian-el (37.8) unstable; urgency=medium
* Do not use shell in call-process (Closes: #905308).
+ * Use view mode for files from INFO buffer (Closes: #623684).
- -- David Bremner <bremner@debian.org> Sat, 20 Oct 2018 11:39:43 -0300
+ -- David Bremner <bremner@debian.org> Sat, 20 Oct 2018 12:13:04 -0300
debian-el (37.7) unstable; urgency=medium