summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-08-05 12:02:20 -0400
committerSean Whitton <spwhitton@spwhitton.name>2017-08-05 12:02:20 -0400
commit52860b78ab4c5582e250c7174e092a4f5eb059d4 (patch)
tree1da8c2dc0221ac328bd2dc62f67677d20d722752 /Makefile
parentca5b8215becc30ac6670f924b031c102c5711ca1 (diff)
WIP: build PNG from .dia
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index beacdf1..3a4de18 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ export DBLATEX = dblatex -p xsl/dblatex.xsl
export MDWN = multimarkdown
export XMLLINT = xmllint --nonet --noout --postvalid --xinclude
export XSLTPROC = xsltproc --nonet --xinclude
+export DIA = dia
# Installation directories. Normally this is only used by debian/rules
# build, which will set DESTDIR to put the installation under the temporary
@@ -48,6 +49,10 @@ FHS_FILES := fhs-2.3.html fhs-2.3.ps.gz fhs-2.3.txt.gz fhs-2.3.pdf.gz
# HTML versions from these.
MDWN_FILES := README autopkgtest
+# Dia diagrams in the dia/ subdirectory.
+DIA_FILES := dia/install.dia dia/install-conffiles.dia dia/upgrade.dia \
+ dia/remove.dia dia/purge.dia dia/remove-purge.dia
+
# DocBook source files in the top-level directory. We do some common actions
# with each of these: build text, HTML, and one-page HTML output.
XML_FILES := menu-policy perl-policy policy
@@ -164,6 +169,9 @@ $(MDWN_FILES:=.txt): %.txt: %.md version.md
$(MDWN_FILES:=.html): %.html: %.md version.md
cat $^ | $(MDWN) > $@
+$(DIA_FILES:=.png): %.png: %.dia
+ dia -e $@ $^
+
# Suppress the table of contents for the standalone upgrading checklist.
upgrading-checklist-1.html: XSLPARAMS = --stringparam generate.toc ''
upgrading-checklist.txt: XSLPARAMS = --stringparam generate.toc ''