summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2017-01-08 13:45:03 +0100
committerRuss Allbery <rra@debian.org>2017-01-14 18:13:06 -0800
commit8427251c445cf591a9a673a57c47ec3101709dc1 (patch)
tree204f6ff5d68eeb44e8465ea436242ee1e3ea033e /Makefile
parent03102505c0303c1c2d6d1d5162ff24bbe7b4b0d1 (diff)
Use MultiMarkdown instead of Org-Mode
This reduces the current formatting languages used from four to three, and removes the build dependency on emacs and the overhead of having to know an application specific formatting language. Closes: #849483
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 10b0f5a..bc649d7 100644
--- a/Makefile
+++ b/Makefile
@@ -4,14 +4,12 @@ policy.sgml: version.ent
menu-policy.sgml: version.ent
perl-policy.sgml: version.ent
-%.txt: %.org
- $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
- --funcall org-ascii-export-to-ascii
+%.txt: %.md
+ cat $^ > $@
test "$@" != "README.txt" || \
- perl -pli -e 's,./Process.org,Process.txt,g' $@
-%.html: %.org
- $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
- --funcall org-html-export-to-html
+ perl -pli -e 's,./Process.md,Process.txt,g' $@
+%.html: %.md
+ $(MDWN) $< > $@
%.validate: %
onsgmls -wall -gues $<