summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-08-05 13:35:02 -0400
committerSean Whitton <spwhitton@spwhitton.name>2017-08-05 13:35:02 -0400
commitdbd5db5a0798a3d92bdff458dc77eb09d5cf29ae (patch)
treec872fa2536eb9c3719cab6e0d72fd06adfef3b17 /Makefile
parent277fa7d4daa8ecce070730e76cf151bce2f32ae1 (diff)
copy PNGs into HTML output
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 13ba6c6..a7d14d5 100644
--- a/Makefile
+++ b/Makefile
@@ -193,11 +193,12 @@ upgrading-checklist.txt: XSLPARAMS = --stringparam generate.toc ''
$(XMLLINT) $<
touch $@
-%.html/index.html: %.xml xsl/html-chunk.xsl version.xml
- mkdir -p $(@D)
+%.html/index.html: %.xml xsl/html-chunk.xsl version.xml $(DIA_PNGS)
+ mkdir -p $(@D)/img
$(XSLTPROC) $(XSLPARAMS) \
--stringparam base.dir $(@D)/ \
xsl/html-chunk.xsl $<
+ cp $(DIA_PNGS) $(@D)/img
$(XML_SINGLE_FILES:=.html): %.html: %.xml xsl/html-single.xsl version.xml
$(XSLTPROC) $(XSLPARAMS) xsl/html-single.xsl $< > $@