summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2016-02-21 14:11:54 +0000
committerJulien Cristau <jcristau@debian.org>2016-02-21 14:11:54 +0000
commit614965b925ea4fbfcc1ebdb28cb8171faaa9e9d7 (patch)
treebc830ff524aa2bcb6facf2d65371e7344f294616
parent08ae04a0cf618b9767283da5a794905aa967b9be (diff)
Fix FTBFS with GCC-5 harder.
It makes no sense to declare functions "inline" and then not provide a definition for them. Closes: #808482.
-rw-r--r--debian/changelog8
-rw-r--r--include/deborphan.h4
-rw-r--r--include/xalloc.h8
-rw-r--r--src/string.c4
-rw-r--r--src/xalloc.c8
5 files changed, 20 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 661fa96..43d5d84 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+deborphan (1.7.28.8-0.3) UNRELEASED; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix FTBFS with GCC-5 harder. It makes no sense to declare functions
+ "inline" and then not provide a definition for them. Closes: #808482.
+
+ -- Julien Cristau <jcristau@debian.org> Sun, 21 Feb 2016 14:07:34 +0000
+
deborphan (1.7.28.8-0.2) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/include/deborphan.h b/include/deborphan.h
index f1729fb..57bcd67 100644
--- a/include/deborphan.h
+++ b/include/deborphan.h
@@ -172,8 +172,8 @@ void print_usage();
int string_to_priority(const char *priority);
const char *priority_to_string(int priority);
char *sstrsep(char **str, int c);
-extern inline void strstripchr(char *s, int c);
-extern inline unsigned int strhash(const char *line);
+void strstripchr(char *s, int c);
+unsigned int strhash(const char *line);
/* keep.c */
dep *readkeep(const char *kfile);
diff --git a/include/xalloc.h b/include/xalloc.h
index ce519ad..761b73a 100644
--- a/include/xalloc.h
+++ b/include/xalloc.h
@@ -7,7 +7,7 @@
Distributed under the terms of the Artistic License.
*/
-extern inline void *xcalloc(size_t nmemb, size_t size);
-extern inline void *xmalloc(size_t size);
-extern inline void *xrealloc(void *ptr, size_t size);
-extern inline char *xstrdup(const char *s);
+void *xcalloc(size_t nmemb, size_t size);
+void *xmalloc(size_t size);
+void *xrealloc(void *ptr, size_t size);
+char *xstrdup(const char *s);
diff --git a/src/string.c b/src/string.c
index 9270917..95abc2e 100644
--- a/src/string.c
+++ b/src/string.c
@@ -13,7 +13,7 @@
/* Simple function to hash a string to an unsigned int.
*/
-inline unsigned int
+unsigned int
strhash(const char *line)
{
unsigned int r = 0;
@@ -30,7 +30,7 @@ strhash(const char *line)
/* This function removes all occurences of the character 'c' from the
string 's'.
*/
-inline void
+void
strstripchr(char *s, int c)
{
register char *t;
diff --git a/src/xalloc.c b/src/xalloc.c
index 115b710..8c830e7 100644
--- a/src/xalloc.c
+++ b/src/xalloc.c
@@ -35,7 +35,7 @@ void free();
# define EXIT_FAILURE 1
#endif /* STDC_HEADERS */
-inline void *
+void *
xrealloc(void *ptr, size_t size)
{
void *t;
@@ -44,7 +44,7 @@ xrealloc(void *ptr, size_t size)
return t;
}
-inline void *
+void *
xcalloc(size_t nmemb, size_t size)
{
void *t;
@@ -55,7 +55,7 @@ xcalloc(size_t nmemb, size_t size)
return t;
}
-inline void *
+void *
xmalloc(size_t size)
{
void *t;
@@ -66,7 +66,7 @@ xmalloc(size_t size)
return t;
}
-inline char *
+char *
xstrdup(const char *s)
{
char *t;