summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-12-11 22:21:17 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-12-11 22:21:17 +0000
commitee3aa8c7c713e7df6078014c4935e765847a09f8 (patch)
tree9cd19e44a61dee917b7f2bed0d82cbf7da25c58b
parentd1f0e595d871c8e51ceca5f83d2a5eb6b20deae7 (diff)
changelog: Tidying
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog29
1 files changed, 17 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index d6ec8c3..3f6970d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,23 +1,28 @@
dgit (10.2~) unstable; urgency=medium
- * dgit: Be more cautious about invoking gdr for making patches.
+ Command line change - dgit rpush vs rpush-source vs rpush-built:
+ * Introduce "dgit rpush-source", a new feature.
+ Closes:#974012. [Request from Wookey]
+ * Introduce "dgit rpush-built", meaning what "dgit rpush" does now.
+ * Make "dgit rpush" a configurable alias, which by default warns about
+ future incompatibility and then runs "dgit rpush-built".
+ (This was done for "dgit push" in dgit 10.0.)
+
+ Bugfixes to dgit:
+ * Be more conservative about when to run "git-debrebase make-patches".
Closes:#1025451. [Report from Sean Whitton]
- * dgit: Cope with "3.0 (quilt)" "include-binaries" feature.
+ * Cope with packages using "3.0 (quilt)" "include-binaries" feature.
Closes:#1024233. [Report from Peter Green]
-
- * dgit: Provide dgit rpush-source, and dgit push-built, and
- prepare for making dgit rpush be dgit rpush-source.
- Closes:#974012. [Request for rpush-source from Wookey]
-
- * dgit(1): Promote push-source more, rather than push-built.
-
- * dgit: Cope with certain packages where dpkg-source guesses wrong
- about patch application status. (Perms-only patches may be related?)
+ * Cope with certain packages where dpkg-source guesses wrong about
+ patch application status. (Perms-only patches may be implicated?)
Closes:#1025694. [Report from Matthew Vernon]
+ Minor improvements:
+ * dgit(1): Promote push-source even more, rather than push-built.
+ * git-debrebase --noop-ok: support --no-noop-ok.
+
Debugging fixes and internal changes:
* dgit: Fix a direct use of chdir, should be changedir
- * git-debrebase --noop-ok: support --no-noop-ok
* git-debrebase --noop-ok: use default destination
--