summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-19 16:27:19 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-19 19:37:08 +0100
commit5f279b026ede8bc694f76c13818cb28e12255fb3 (patch)
treeee659d523c95b3cc15156f50fda4c140c9330858
parentb4fb53aea490a1e6e401712bc23cc790638e1dcc (diff)
dgit(1): Reorganise and complete the configuration section.
-rw-r--r--debian/changelog1
-rw-r--r--dgit.165
2 files changed, 46 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index 029375b..462f7bd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ dgit (0.31~~) unstable; urgency=low
Documentation:
* dgit(1): Remove some obsolete caveats from BUGS.
* dgit(1); Mention that -wgf can avoid need for build-deps.
+ * dgit(1): Reorganise and complete the configuration section.
Useability improvements:
* Provide -wdd aka --clean=dpkg-source-d. Closes:#792433.
diff --git a/dgit.1 b/dgit.1
index dd083ac..808c3a5 100644
--- a/dgit.1
+++ b/dgit.1
@@ -587,17 +587,44 @@ Then run
.BR "dgit push"
to actually upload the result.
.SH CONFIGURATION
-dgit looks at the following git config keys to control its behaviour.
-You may set them with git-config (either in system-global or per-tree
+dgit can be configured via the git config system.
+You may set keys with git-config (either in system-global or per-tree
configuration), or provide
.BI -c key = value
on the dgit command line.
+.LP
+Settings likely to be useful for an end user include:
.TP
-.BI dgit-suite. suite .distro
+.BR dgit-suite. \fIsuite\fR .distro " \fIdistro\fR"
+Specifies the distro for a suite. dgit keys off the suite name (which
+appears in changelogs etc.), and uses that to determine the distro
+which is involved. The config used is thereafter that for the distro.
+it then looks
.TP
-.BI dgit.default.distro
+.BI dgit.default.distro " distro"
+The default distro for an unknown suite.
.TP
-.BR dgit-distro. \fIdistro\fR .readonly " " auto | true | false
+.BR dgit-distro. \fIdistro\fR .readonly " " auto | a " | " true | t | y | 1 " | " false | f | n | 0
+Whether you have push access to the distro.
+For Debian, it is OK to use auto, which uses readonly mode if you are
+not pushing right now,
+but setting this to false will avoid relying on the mirror of the dgit
+git repository server.
+.TP
+.BI dgit-distro. distro .keyid
+.TP
+.BI dgit-distro. distro .mirror " url"
+.TP
+.BI dgit-distro. distro .username
+Not relevant for Debian.
+.TP
+.BI dgit-distro. distro .upload-host
+Might be useful if you have an intermediate queue server.
+.SH ACCESS CONFIGURATION
+There are many other settings which specify how a particular distro's
+services (archive and git) are provided. These should not normally be
+adjusted, but are documented for the benefit of distros who wish to
+adopt dgit.
.TP
.BR dgit-distro. \fIdistro\fR /push. *
If set, overrides corresponding non \fB/push\fR config when
@@ -605,39 +632,37 @@ If set, overrides corresponding non \fB/push\fR config when
or when pushing and
.BR readonly=auto .
.TP
-.BI dgit-distro. distro .username
-.TP
.BI dgit-distro. distro .git-url
.TP
-.BI dgit-distro. distro .git-user
-.TP
-.BI dgit-distro. distro .git-host
+.BR dgit-distro. \fIdistro\fR .git-url [ -suffix ]
.TP
.BI dgit-distro. distro .git-proto
.TP
.BI dgit-distro. distro .git-path
.TP
-.BI dgit-distro. distro .git-check
+.BR dgit-distro. \fIdistro\fR .git-check " " true | false | url | ssh-cmd
.TP
-.BI dgit-distro. distro .git-create
+.BI dgit-distro. distro .git-check-suffix
.TP
-.BI dgit-distro. distro .upload-host
+.BR dgit-distro. \fIdistro\fR .diverts.divert " " new-distro | / \fIdistro-suffix\fR
.TP
-.BI dgit-distro. distro .mirror
+.BI dgit-distro. distro .git-create " " ssh-cmd | true
.TP
-.BI dgit-distro. distro .archive-query
+.BR dgit-distro. \fIdistro\fR .archive-query " " ftpmasterapi: " | " madison: "\fIdistro\fR | " dummycat: "\fI/path\fR | " sshpsql: \fIuser\fR @ \fIhost\fR : \fIdbname\fR
.TP
-.BI dgit-distro. distro .archive-query-default-component
+.BR dgit-distro. \fIdistro\fR .archive-query- ( url | tls-key | curl-ca-args )
+.TP
+.BI dgit-distro. distro .madison-distro
.TP
-.BI dgit-distro. distro .sshpsql-user
+.BI dgit-distro. distro .archive-query-default-component
.TP
-.BI dgit-distro. distro .sshpsql-host
+.BI dgit-distro. distro .ssh
.TP
.BI dgit-distro. distro .sshpsql-dbname
.TP
-.BI dgit-distro. distro .ssh
+.BR dgit-distro. \fIdistro\fR . ( git | sshpsql ) - ( user | host | user-force )
.TP
-.BI dgit-distro. distro .keyid
+.BI dgit-distro. distro .backports-quirk
.TP
.BR dgit.default. *
for each