summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-30 19:03:10 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-30 19:18:43 +0100
commit8916ea3e2ca88820e6ad1d0c8823a37221f8ed88 (patch)
tree501c08c8a336ede6fa1a3a76a0ef07896ca6186a
parent690272dfb77eefa9277970dafe4bbb47de3b35e1 (diff)
test suite: gpg agent workaround: Fix bugs in log neatening.debian/5.5+exp9archive/debian/5.5+exp9
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog6
-rwxr-xr-xtests/tstunt/gpg8
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3f363e4..852adc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.5+exp9) experimental; urgency=medium
+
+ * test suite: gpg agent workaround: Fix bugs in log neatening.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 30 Jun 2018 19:03:00 +0100
+
dgit (5.5+exp8) experimental; urgency=medium
* test suite: gpg agent workaround: Neaten the logging.
diff --git a/tests/tstunt/gpg b/tests/tstunt/gpg
index 7e12846..4214b4a 100755
--- a/tests/tstunt/gpg
+++ b/tests/tstunt/gpg
@@ -6,14 +6,16 @@ with-lock-ex -w "$DGIT_TEST_GNUPG_GLOBAL_LOCK" \
sh -c '
"$@" 9>&2 2>>"$DGIT_TEST_GNUPG_LOG"
rc=$?
- if [ rc = 0 ]; then exit 0; fi
+ if [ $rc = 0 ]; then exit 0; fi
if [ "x$DGIT_TEST_BYHAND" != x ]; then
- echo >&2 "BYHAND, not catting $DGIT_TEST_GNUPG_LOG"
+ echo >&2 "BYHAND, not dumping $DGIT_TEST_GNUPG_LOG"
else
echo >&2 "########################################"
echo >&2 "$DGIT_TEST_GNUPG_LOG"
- cat >&2 "$DGIT_TEST_GNUPG_LOG"
+ sed '\''s/^/\[gnupg-workarounds] /'\'' >&2 \
+ "$DGIT_TEST_GNUPG_LOG"
echo >&2 "end of $DGIT_TEST_GNUPG_LOG"
+ echo >&2 "########################################"
fi
exit $rc
' x \