summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 15:29:15 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 15:29:15 +0100
commitb87783b9ba972689d934d25650481feec1cdd06d (patch)
tree213cfed80ef90d85061ff150957a0f49cc45a36a
parent348b995ead9fbcab890da5d222af36402f33d68c (diff)
Cope with new git-buildpackage which provides gbp, rather than the eponymous command, on PATH.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit12
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index de42010..0803637 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ dgit (1.1~~) unstable; urgency=low
command line arguments when massaging the dpkg-buildpackage arguments,
so that we don't end up giving dpkg-buildpackage contradictory
instructions.
+ * Cope with new git-buildpackage which provides gbp, rather than the
+ eponymous command, on PATH.
Configurability:
* Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD. Closes:#793427.
diff --git a/dgit b/dgit
index 21cbd56..9c4d3d6 100755
--- a/dgit
+++ b/dgit
@@ -2973,9 +2973,15 @@ sub cmd_build {
sub cmd_gbp_build {
my @dbp = @dpkgbuildpackage;
massage_dbp_args \@dbp, \@ARGV;
- my @cmd =
- (qw(git-buildpackage -us -uc --git-no-sign-tags),
- "--git-builder=@dbp");
+
+ my @cmd;
+ if (length executable_on_path('git-buildpackage')) {
+ @cmd = qw(git-buildpackage);
+ } else {
+ @cmd = qw(gbp buildpackage);
+ }
+ push @cmd, (qw(-us -uc --git-no-sign-tags), "--git-builder=@dbp");
+
if ($cleanmode eq 'dpkg-source') {
$suppress_clean = 1;
} else {