summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-09 21:37:52 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-12-19 16:58:57 +0000
commitf93eae496d1ab8aebe85d9080c4e372ebe9b3715 (patch)
tree83433005795c91dff3af56229e3129a2bc1e25ed
parent0e02391d91eaff9f4e6432baadb6996b39b68b91 (diff)
Version tags mangling: Protect dots, as per proposed update to DEP-14.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Debian/Dgit.pm3
-rw-r--r--debian/changelog1
2 files changed, 3 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index a3c2753..1bac97b 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -147,8 +147,9 @@ sub debugcmd {
sub dep14_version_mangle ($) {
my ($v) = @_;
- # DEP-14 2014-11-05 "Version Mangling"
+ # DEP-14 patch proposed 2016-11-09 "Version Mangling"
$v =~ y/~:/_%/;
+ $v =~ s/\.(?=\.|$|lock$)/.#/g;
return $v;
}
diff --git a/debian/changelog b/debian/changelog
index 5211a3c..4ee6485 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (2.12~) unstable; urgency=medium
GIT_ALTERNATE_OBJECT_DIRECTORIES in the pre-receive-hook.
* dgit-maint-merge(7): Explain how to change to this workflow
from an existing git workflow. [Sean Whitton] Closes:#847807.
+ * Version tags mangling: Protect dots, as per proposed update to DEP-14.
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian