summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-08-04 02:05:10 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-08-04 02:05:10 +0100
commit0ebf9dfcc7a8c45e3b8b2db4a711b7deeff7f8bc (patch)
tree80a23ec531453f02b5ba91f7858a63cb8f482923
parent6b0c4982c4d3aa25970e87df150162e7cd4160c1 (diff)
Improve error message for .dsc parsing failures more generally.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index eccb21a..bf13834 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -35,6 +35,7 @@ dgit (0.22~experimental1) experimental; urgency=low
(and put an appropriate caveat in the manpage). Closes:#740687.
* Improve error message for .dsc having already been signed (iff
using libdpkg-perl 1.17.x)
+ * Improve error message for .dsc parsing failures more generally.
Major new feature, currently stalled awaiting server infrastructure:
* dgit-repos-server: New program for receiving signed-tag-based
diff --git a/dgit b/dgit
index ebeb880..b242646 100755
--- a/dgit
+++ b/dgit
@@ -603,7 +603,7 @@ sub parsecontrolfh ($$;$) {
$opts{allow_pgp}= $allowsigned || !$dpkgcontrolhash_noissigned;
print STDERR Dumper(\%opts);
$c = Dpkg::Control::Hash->new(%opts);
- $c->parse($fh) or die "parsing of $desc failed";
+ $c->parse($fh,$desc) or die "parsing of $desc failed";
last if $allowsigned;
last if $dpkgcontrolhash_noissigned;
my $issigned= $c->get_option('is_pgp_signed');