summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 16:33:08 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 17:58:34 +0100
commit182693923d60c6e869e7c07b113bf65bce816f3f (patch)
tree490d4c11d01f7b51997ab67c282418fa688200ac
parentd6be829bf56e699d27d388026d4af7ab710ba328 (diff)
Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch (using setup_sigwarn).
-rw-r--r--debian/changelog2
-rwxr-xr-xinfra/dgit-repos-admin-debian7
-rwxr-xr-xinfra/dgit-ssh-dispatch4
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 2e6e744..2a49514 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -28,6 +28,8 @@ dgit (1.1) unstable; urgency=low
* Work around #793471 (madness with $SIG{__WARN__} and Perl's system
builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
check getppid.
+ * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
+ (using setup_sigwarn).
--
diff --git a/infra/dgit-repos-admin-debian b/infra/dgit-repos-admin-debian
index 926431b..e292bfa 100755
--- a/infra/dgit-repos-admin-debian
+++ b/infra/dgit-repos-admin-debian
@@ -1,6 +1,11 @@
#!/usr/bin/perl -w
# dgit repos policy admin script for Debian
+use strict;
+
+use Debian::Dgit;
+setup_sigwarn();
+
our $usage = <<'END';
usage:
dgit-repos-admin-debian [<options>] operation...
@@ -16,11 +21,9 @@ operations:
untaint [--global|<package>] <gitobjid>
END
-use strict;
use POSIX;
use DBI;
-use Debian::Dgit;
use Debian::Dgit::Policy::Debian;
sub badusage ($) { die "bad usage: $_[0]\n$usage"; }
diff --git a/infra/dgit-ssh-dispatch b/infra/dgit-ssh-dispatch
index 9c023d8..17db268 100755
--- a/infra/dgit-ssh-dispatch
+++ b/infra/dgit-ssh-dispatch
@@ -1,9 +1,11 @@
#!/usr/bin/perl -w
use strict;
-use POSIX;
use Debian::Dgit;
+setup_sigwarn();
+
+use POSIX;
open DEBUG, '>/dev/null' or die $!;
if (@ARGV && $ARGV[0] eq '-D') {