summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-04-15 18:05:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-04-15 18:05:09 +0100
commit233fa856bec4d90e55531f54b81a264273cd4cb8 (patch)
tree9c64a0304097bfff9a8d9cd1155de4c906502990
parent96ac307f0b9d186d589d221dabfb0e403169aa08 (diff)
Fix inaccurate error message when archive's git hash is not an ancestor of git repo's git hash.
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5422a93..a5abed6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -58,6 +58,9 @@ dgit (0.23~) unstable; urgency=low
* Document in manpage under `dgit push' that it is best to build with
dgit too. Closes:#763333.
+ * Fix inaccurate error message when archive's git hash is not an
+ ancestor of git repo's git hash.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 2e67eb5..a73fffd 100755
--- a/dgit
+++ b/dgit
@@ -1355,8 +1355,8 @@ $later_warning_msg
END
$hash = $lastpush_hash;
} else {
- fail "archive's .dsc refers to ".$dsc_hash.
- " but this is an ancestor of ".$lastpush_hash;
+ fail "git head (".lrref()."=$lastpush_hash) is not a ".
+ "descendant of archive's .dsc hash ($dsc_hash)";
}
} elsif ($dsc) {
$hash = generate_commit_from_dsc();