summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-29 02:02:26 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-29 02:02:26 +0100
commit5016ae374676ed5dbf594a4fde97ac5603880e4a (patch)
tree9e8aa3bcdf572314721dc974a5810143f536951b
parent76cbbc78a07e44b4c917bbaa93bf7cd602387082 (diff)
Fix an undef reference in error message processing when quilt fixup linearisation fails.
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit2
-rwxr-xr-xinfra/dgit-ssh-dispatch1
3 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b0587c6..a34f218 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -67,6 +67,9 @@ dgit (0.23~) unstable; urgency=low
* Show git config queries only with debuglevel 3 (-DDD) and higher.
+ * Fix an undef reference in error message processing when quilt
+ fixup linearisation fails.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 31b5bf4..0d558c0 100755
--- a/dgit
+++ b/dgit
@@ -2270,7 +2270,7 @@ sub quiltify ($$) {
my $s = $abbrev->($notp);
my $c = $notp->{Child};
$s .= "..".$abbrev->($c) if $c;
- $s .= ": ".$c->{Whynot};
+ $s .= ": ".$notp->{Whynot};
return $s;
};
if ($quilt_mode eq 'linear') {
diff --git a/infra/dgit-ssh-dispatch b/infra/dgit-ssh-dispatch
index 6d4efbf..ed9a23d 100755
--- a/infra/dgit-ssh-dispatch
+++ b/infra/dgit-ssh-dispatch
@@ -32,6 +32,7 @@ our $qre = '["'."']?";
# diverts should be list of
# <pat> [<divert-to>]
# where <pat> is a package name pattern which may contain * or literals.
+# <divert-to> is for `git config dgit-distro.DISTRO.diverts.<divert-to>'
our ($distro,$pkg, $d);
our ($dgitlive,$repos,$suites,$diverts,$policyhook,$repo);