summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-11-07 00:02:52 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-11-07 00:02:52 +0000
commit631c9e09a7fd22a5847173978c3d1357c1db74ea (patch)
treec056032ddb355218605fb7af505388e958bf925f
parent86ad8bd4c1026392b4b758e8c0cfd6b39c3cfc03 (diff)
Clarify error message for missing refs/remotes/dgit/dgit/<suite>.debian/0.17
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit6
2 files changed, 5 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f31f38..eab01a0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,9 @@ dgit (0.17) unstable; urgency=high
* Do not grobble around in .git/refs/; instead, use git-show-ref.
This avoids breaking when git makes packed refs. Closes:728893.
+ * Clarify error message for missing refs/remotes/dgit/dgit/<suite>.
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 07 Nov 2013 00:02:47 +0000
dgit (0.16) unstable; urgency=high
diff --git a/dgit b/dgit
index 16bf56d..207b5d0 100755
--- a/dgit
+++ b/dgit
@@ -745,9 +745,9 @@ sub fetch_from_archive () {
print DEBUG "previous reference hash=$lastpush_hash\n";
my $hash;
if (defined $dsc_hash) {
- fail "missing git history even though dsc has hash -".
- " could not find commit $dsc_hash".
- " (should be in ".access_giturl()."#".rrref().")"
+ fail "missing remote git history even though dsc has hash -".
+ " could not find ref ".lrref().
+ " (should have been fetched from ".access_giturl()."#".rrref().")"
unless $lastpush_hash;
$hash = $dsc_hash;
ensure_we_have_orig();