summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-25 16:00:50 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-25 16:02:47 +0100
commit69c8de09ff5cb507a7628282d346c2c8fd487a86 (patch)
tree465a3d32d1e1455f24fc4b0eae568fc503ddd22c
parent9a0e08c9ff1d9b3a53e8399290afcee426f76f7c (diff)
build changes handling: Run mergechanges when needed in non-sbuild build modes
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit15
2 files changed, 15 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 14fbbeb..f36ae86 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (2.8~) unstable; urgency=low
* absurd git-apply fallback: defend against debian/patches/series
being an unusual object, in case dpkg-source doesn't.
+ * When in split build mode for `gbp-build' or `build', run
+ mergechanges as is required. Closes:#841990.
--
diff --git a/dgit b/dgit
index 356b48c..d6a6326 100755
--- a/dgit
+++ b/dgit
@@ -4938,6 +4938,17 @@ END
printdone "build successful, results in $result\n" or die $!;
}
+sub postbuild_mergechanges_vanilla ($) {
+ my ($wantsrc) = @_;
+ if ($wantsrc == 1) {
+ in_parent {
+ postbuild_mergechanges(undef);
+ };
+ } else {
+ printdone "build successful\n";
+ }
+}
+
sub cmd_build {
my @dbp = (@dpkgbuildpackage, qw(-us -uc), changesopts_initial(), @ARGV);
my $wantsrc = massage_dbp_args \@dbp;
@@ -4952,7 +4963,7 @@ sub cmd_build {
runcmd_ordryrun_local @dbp;
}
maybe_unapply_patches_again();
- printdone "build successful\n";
+ postbuild_mergechanges_vanilla $wantsrc;
}
sub pre_gbp_build {
@@ -4988,7 +4999,7 @@ sub cmd_gbp_build {
push @cmd, changesopts();
runcmd_ordryrun_local @cmd, @ARGV;
}
- printdone "build successful\n";
+ postbuild_mergechanges_vanilla $wantsrc;
}
sub cmd_git_build { cmd_gbp_build(); } # compatibility with <= 1.0