summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-29 12:11:56 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-29 12:11:57 +0100
commit7d0d834d7b41b5f3cafffc37b9a9d94966c68e0f (patch)
treeb223437f144e7b3a3ceddea0648f3ab7578c94ec
parent641b95390e9ff7fea44a0c4ec4181b10be0b78c1 (diff)
test suite: gpg-agent workaround: Add more debugging output.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog6
-rwxr-xr-xtests/tstunt/gpg-withagent15
2 files changed, 21 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 41a6710..7850597 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.5+exp5~) experimental; urgency=medium
+
+ * test suite: gpg-agent workaround: Add more debugging output.
+
+ --
+
dgit (5.5+exp4) experimental; urgency=medium
* test suite: Add bc to appropriate test Depends.
diff --git a/tests/tstunt/gpg-withagent b/tests/tstunt/gpg-withagent
index 4cb5d4e..d7fe793 100755
--- a/tests/tstunt/gpg-withagent
+++ b/tests/tstunt/gpg-withagent
@@ -1,9 +1,18 @@
#!/bin/sh
set -ex
+d () {
+ date --iso-8601=ns >&2
+ ps -ef | grep gpg-agent >&2
+}
+
+d
+
retry_until_ok () {
sleeptime=0
+ d
while ! "$@"; do
+ d
case $sleeptime in
??.*)
echo >&2 "$0: GPG AGENT STARTP $@ TIMED OUT"
@@ -29,12 +38,16 @@ retry_until_ok agent_is_running
echo >&2 'GPG-WITHAGENT... RUNNING'
+d
+
set +e
$DGIT_TEST_REAL_GPG \
--agent-program=$DGIT_STUNT_AGENT "$@"
rc=$?
set -e
+d
+
echo >&2 'GPG-WITHAGENT... STOPPING'
kill_agent_not_running () {
@@ -48,4 +61,6 @@ retry_until_ok kill_agent_not_running
echo >&2 'GPG-WITHAGENT... DONE'
+d
+
exit $rc