summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-22 16:48:21 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-22 16:48:22 +0100
commit866feb162b8f7e84039ed80e206c0df0def5f6c5 (patch)
tree0c1df58bb21439cfc0d0097727d594cf7cfa2cd2
parent3405b073420845d4e72202577537e013d91abd25 (diff)
dgit: git-debrebase interop: Actually tolerate git-debrebase status 7
make-patches exiting with status 7 causes $?==7*256, not 7. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8f093d4..009e19f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,6 +27,8 @@ dgit (5.2~) unstable; urgency=medium
* Print a warning to stderr on `dgit fetch sid', if your vcs-git
remote url disagrees with what's in sid's .dsc.
* git-debrebase interop: Add a missing debugcmd debugging print.
+ * git-debrebase interop: Actually tolerate git-debrebase make-patches
+ exiting with status 7.
test suite:
* Use nproc(1) rather than Sys::CPU. This is more portable and does not
diff --git a/dgit b/dgit
index 88db243..5c9cdc3 100755
--- a/dgit
+++ b/dgit
@@ -5571,7 +5571,7 @@ END
if (act_local()) {
debugcmd "+",@cmd;
$!=0; $?=-1;
- failedcmd @cmd if system @cmd and $?!=7;
+ failedcmd @cmd if system @cmd and $?!=7*256;
} else {
dryrun_report @cmd;
}