summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-18 19:01:26 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-18 19:06:26 +0100
commit86a5d4d40d42f13f7bcf9cd28edcc0e2bb779be4 (patch)
tree16cf4384abacae8d6062597bc9caa59f3d221f56
parent7219d9e82ddbe5b7e34587329e73549bba4ef85e (diff)
dgit gbp-build: No longer invent a --git-debian-branch option.
Usually the user is a maintainer using split brain, and we should rely on their own gbp configuration to specify the right check. Closes:#841100. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit4
2 files changed, 4 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1c944a7..33b627e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
dgit (2.4~) unstable; urgency=low
- *
+ * dgit gbp-build: No longer invent a --git-debian-branch option.
+ Usually the user is a maintainer using split brain, and we should rely
+ on their own gbp configuration to specify the right check.
+ Closes:#841100.
--
diff --git a/dgit b/dgit
index 2cbb2fd..c03c031 100755
--- a/dgit
+++ b/dgit
@@ -4853,10 +4853,6 @@ sub cmd_gbp_build {
}
maybe_unapply_patches_again();
if ($wantsrc < 2) {
- unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
- canonicalise_suite();
- push @cmd, "--git-debian-branch=".lbranch();
- }
push @cmd, changesopts();
runcmd_ordryrun_local @cmd, @ARGV;
}