summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-22 13:58:50 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-22 13:58:50 +0100
commit8f04e1aea8377adbd2e8b178a32b31770373e902 (patch)
treeda23a552aa7e14f7b4958940ed22f7cb197629db
parent08a4cefb989b93dec53d5357e3b40d04340884cc (diff)
in check_not_dirty, diff against HEAD as that's what we care about
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 14b3463..1de5750 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ dgit (0.4) experimental; urgency=low
* Better error checking when parsing RFC822-style control data.
* Better checking that the supplied .dsc and debian/changes correspond.
* Ordering improvement in push: don't add dsc field until git push done.
+ * Bugfixes.
--
diff --git a/dgit b/dgit
index e95f30c..eb263b1 100755
--- a/dgit
+++ b/dgit
@@ -701,7 +701,7 @@ sub pull () {
}
sub check_not_dirty () {
- runcmd @git, qw(diff --quiet);
+ runcmd @git, qw(diff --quiet HEAD);
}
sub commit_quilty_patch ($) {