summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-26 04:22:42 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-26 04:22:43 +0100
commit9b1710555b3d13149437428cd2d8b4b3d5209132 (patch)
treebe9c1c7276652dbba671bf9e57b9b43534cd2851
parent67e3687e3223a97f2d2952ba2aba32d0c177966b (diff)
dgit: Rename --ignore-dirty to --include-dirty
Leaving the old name supported as a deprecated alias. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
-rw-r--r--dgit.19
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index c0bbcb9..d936d22 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,8 @@ dgit (5.11~) unstable; urgency=medium
configuration key. Closes:#857316. [ Sean Whitton. ]
Still does not always work, due to #863582.
* dgit: Minor internal improvements.
+ * dgit: Rename --ignore-dirty to --include-dirty (leaving the old
+ name supported as a deprecated alias).
--
diff --git a/dgit b/dgit
index eca2303..2dd8ef1 100755
--- a/dgit
+++ b/dgit
@@ -6864,7 +6864,7 @@ sub parseopts () {
} elsif (m/^--(gbp|dpm)$/s) {
push @ropts, "--quilt=$1";
$quilt_mode = $1;
- } elsif (m/^--ignore-dirty$/s) {
+ } elsif (m/^--(?:ignore|include)-dirty$/s) {
push @ropts, $_;
$includedirty = 1;
} elsif (m/^--no-quilt-fixup$/s) {
diff --git a/dgit.1 b/dgit.1
index ddb0c0a..f0d637d 100644
--- a/dgit.1
+++ b/dgit.1
@@ -529,12 +529,17 @@ refuse to push. It may (for Debian, will) be unable to access the git
history for any packages which have been newly pushed and have not yet
been published.
.TP
-.BR --ignore-dirty
-Do not complain if the working tree does not match your git HEAD.
+.BR --include-dirty
+Do not complain if the working tree does not match your git HEAD,
+and when building,
+include the changes from your working tree.
This can be useful with build, if you plan to commit later. (dgit
push will still ensure that the .dsc you upload and the git tree
you push are identical, so this option won't make broken pushes.)
.TP
+.BR --ignore-dirty
+Deprecated alias for --include-dirty.
+.TP
.BR --overwrite [=\fIprevious-version\fR]
Declare that your HEAD really does contain
all the (wanted) changes