summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-16 18:32:20 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-16 18:32:25 +0100
commit67076f7426abe4204d133325bd632eb4bd8e2c68 (patch)
tree6f076bcfdfc4744f1b9a108f75ab72d607bbfa18
parenta85458a7fc736f6d404622a427380a41f1248765 (diff)
dgit: Import handling Do not crash due in clone
Previously we failed to handle dpkg-parsechangelog SIGPIPE. Closes:#840989. Fixes: dgit: failed command: dpkg-parsechangelog --format rfc822 --all dgit: subprocess died due to fatal signal PIPE Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e35438e..505f392 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
dgit (2.1~~) unstable; urgency=medium
+ * Do not crash due in clone to failure to handle dpkg-parsechangelog
+ SIGPIPE. Closes:#840989. Avoids:
+ dgit: failed command: dpkg-parsechangelog --format rfc822 --all
+ dgit: subprocess died due to fatal signal PIPE
* git- prefixes: Fix some occurrences of `git-foo' in infrastructure,
messages, and test suite. Filter out .../git-core from PATH in
test suite so that we catch future occurrences.
diff --git a/dgit b/dgit
index 0507899..a568c57 100755
--- a/dgit
+++ b/dgit
@@ -1846,7 +1846,7 @@ sub generate_commits_from_dsc () {
printdebug "import clog $r1clogp->{version} becomes r1\n";
}
die $! if CLOGS->error;
- close CLOGS or $?==(SIGPIPE<<8) or failedcmd @clogcmd;
+ close CLOGS or $?==SIGPIPE or failedcmd @clogcmd;
$clogp or fail "package changelog has no entries!";