summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-18 15:35:17 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-18 15:35:17 +0100
commit3d241c37fc1139f8942299323d72fc2e493f036c (patch)
treeff0d9f81aec03336c179a0207b5465971ea4eac1
parent19d5fe05b5568ba5e8119f302f0bb9cbc043e732 (diff)
When running git-add in commit-quilty-patch, use -f and sometimes -A, so as to avoid being broken by any .gitignore, etc.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 9177e0e..cd360c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (1.4~~) UNRELEASED; urgency=low
ac221d67, bug released in 0.22).
* When running git-add in commit-quilty-patch, properly escape
filenames (which git-add treats as glob patterns).
+ * When running git-add in commit-quilty-patch, use -f and sometimes -A,
+ so as to avoid being broken by any .gitignore, etc.
--
diff --git a/dgit b/dgit
index baf3096..916177c 100755
--- a/dgit
+++ b/dgit
@@ -1784,7 +1784,7 @@ sub commit_quilty_patch () {
return;
}
my @adds = map { s/[][*?\\]/\\$&/g; $_; } sort keys %adds;
- runcmd_ordryrun_local @git, qw(add), @adds;
+ runcmd_ordryrun_local @git, qw(add -f), @adds;
commit_admin "Commit Debian 3.0 (quilt) metadata";
}
@@ -2526,7 +2526,7 @@ sub quiltify ($$) {
remove_stray_gits();
mktree_in_ud_here();
rmtree '.pc';
- runcmd @git, 'add', '.';
+ runcmd @git, qw(add -Af .);
my $oldtiptree=git_write_tree();
changedir '../work';