summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-12-19 14:45:18 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-12-19 16:58:57 +0000
commit83f9c7600efd098a5c4a5d4b1938f4df8acfd54a (patch)
tree38dcde39c206222f1f5bc1906a97699776cb584b
parent815eb9d89a743bcd20e566eaabbfd2233109b24b (diff)
Produce better error reporting when absurd git wrapper fails on a patch
during .dsc import. Apropos of #848391. gbp swallows the error from the first run (without --whitespace=fix). Previously only that first run would do anything useful; the second would complain about --whitespace=fix. So failures of dpkg-source would always produce a useless error message. Instead, tolerate (and ignore) the --whitespace=fix option which gbp passes during the second run. This means that the second run tries to do the actual work. This only does extra work if the first run failed, and since the first and second runs are now equivalent, that happens when the second run fails too. But in return for that extra work, we get a report which actually mentions something that unexpectedly went wrong. (The alternative would be to have absurd/git try to stash and then reproduce its previous error, or to make more fragile assumptions about gbp's behaviour.) Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xabsurd/git3
-rw-r--r--debian/changelog2
2 files changed, 5 insertions, 0 deletions
diff --git a/absurd/git b/absurd/git
index 8605008..8300b0b 100755
--- a/absurd/git
+++ b/absurd/git
@@ -56,6 +56,9 @@ for arg in "$@"; do
index=1
continue
;;
+ 1.--whitespace=fix)
+ continue
+ ;;
?.-*)
fail "UNKNOWN OPTION $arg ($*)"
;;
diff --git a/debian/changelog b/debian/changelog
index bca0690..cdd7f25 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,8 @@ dgit (2.12~) unstable; urgency=medium
tag, even in non-split-view quilt modes. Closes:#844129.
* Do not fail when cloning a package containing dangling symlinks.
Closes:#848512.
+ * Produce better error reporting when absurd git wrapper fails
+ on a patch during .dsc import. Apropos of #848391.
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian