summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-06-30 19:57:53 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-01 22:52:39 +0100
commit8b21e27c6d1fb3d3d7c1da290f2e6f3bc278b40a (patch)
tree65ae177ee0246b5ed2239e8db6328bf310ef3ba2
parentcb99709100a32fdb6a1544f4bf9aac8c5f2b4804 (diff)
build_source: Fix bad Perl poetry style
Pass --ch:* and -v options to dpkg-buildpackage when building source. Fixes bad Perl poetry syntax. Closes:#829121.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit8
2 files changed, 6 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 98a03d2..f267d1d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ dgit (1.5~~) unstable; urgency=medium
`dgit clone' cannot create the destination directory.
* Properly substitute $changesfile in one of the `You can retry'
messages. Closes:#800078.
+ * Pass --ch:* and -v options to dpkg-buildpackage when building
+ source. Fixes bad Perl poetry syntax. Closes:#829121.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 0b66d39..de7ee0c 100755
--- a/dgit
+++ b/dgit
@@ -3109,11 +3109,11 @@ sub build_source {
$sourcechanges = "${package}_".(stripepoch $version)."_source.changes";
$dscfn = dscfn($version);
if ($cleanmode eq 'dpkg-source') {
- runcmd_ordryrun_local (@dpkgbuildpackage, qw(-us -uc -S)),
- changesopts();
+ runcmd_ordryrun_local @dpkgbuildpackage, qw(-us -uc -S),
+ changesopts();
} elsif ($cleanmode eq 'dpkg-source-d') {
- runcmd_ordryrun_local (@dpkgbuildpackage, qw(-us -uc -S -d)),
- changesopts();
+ runcmd_ordryrun_local @dpkgbuildpackage, qw(-us -uc -S -d),
+ changesopts();
} else {
my $pwd = must_getcwd();
my $leafdir = basename $pwd;