summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-26 22:53:52 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 03:51:45 +0100
commit99f7db251233b9f6fb735e775e5ceb18a46e066d (patch)
treedf645339103a4e2216b35431f9cfa0bd0f5c6612
parent645bbb33ab2931d242a22689bd51fc73bce7bdac (diff)
When key to use not specified any other way, use the debian/changelog trailer line. Closes:#793423.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
-rw-r--r--dgit.14
3 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 3a54ce5..34b9388 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -49,6 +49,8 @@ dgit (1.1~~) unstable; urgency=low
or DEBEMAIL/DEBFULLNAME. Closes:#793410.
* Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
before the actual header, so dgit works with https_proxy set (!)
+ * When key to use not specified any other way, use the debian/changelog
+ trailer line. Closes:#793423.
--
diff --git a/dgit b/dgit
index 6226bce..270f925 100755
--- a/dgit
+++ b/dgit
@@ -1875,6 +1875,9 @@ END
if (!defined $keyid) {
$keyid = access_cfg('keyid','RETURN-UNDEF');
}
+ if (!defined $keyid) {
+ $keyid = getfield $clogp, 'Maintainer';
+ }
unlink $tfn->('.tmp.asc') or $!==&ENOENT or die $!;
my @sign_cmd = (@gpg, qw(--detach-sign --armor));
push @sign_cmd, qw(-u),$keyid if defined $keyid;
diff --git a/dgit.1 b/dgit.1
index e8f7eb2..dcf4408 100644
--- a/dgit.1
+++ b/dgit.1
@@ -260,8 +260,8 @@ Use
for signing the tag and the upload. The default comes from the
distro's
.B keyid
-config setting (see CONFIGURATION, below), or failing that, gnupg's
-default.
+config setting (see CONFIGURATION, below), or failing that, the
+uploader trailer line in debian/changelog.
.TP
.BR --no-sign
does not sign tags or uploads (meaningful only with push).