summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-16 13:07:59 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-16 13:11:49 +0100
commita85458a7fc736f6d404622a427380a41f1248765 (patch)
tree81c8569dcff07e4b868004c9e20759528bdc5e58
parent3c2a1558b51d714fff35f1f053c10021219a6fe0 (diff)
Test suite: Filter out .../git-core from PATH so that we catch git-foo
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rw-r--r--tests/lib2
-rw-r--r--tests/lib-core11
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 9bf33e4..e35438e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,8 @@
dgit (2.1~~) unstable; urgency=medium
* git- prefixes: Fix some occurrences of `git-foo' in infrastructure,
- messages, and test suite.
+ messages, and test suite. Filter out .../git-core from PATH in
+ test suite so that we catch future occurrences.
--
diff --git a/tests/lib b/tests/lib
index 6401f93..275d3ef 100644
--- a/tests/lib
+++ b/tests/lib
@@ -21,6 +21,8 @@ END
trap 'test $? = 0 || t-report-failure' EXIT
+t-filter-out-git-hyphen-dir
+
t-set-intree
: ${DGIT_TEST_DEBUG=-D}
diff --git a/tests/lib-core b/tests/lib-core
index f3881ca..b01a6ea 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -21,3 +21,14 @@ t-set-using-tmp () {
export DGIT_TEST_TMP=$tmp
export GNUPGHOME=$tmp/gnupg
}
+
+t-filter-out-git-hyphen-dir () {
+ local pathent=$(type -p git-rev-parse ||:)
+ case "$pathent" in '') return ;; esac
+ pathent=${pathent%/*}
+ local path=":$PATH:"
+ path="${path//:$pathent:/}"
+ path="${path#:}"
+ path="${path%:}"
+ PATH="$path"
+}