summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-16 00:47:01 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-16 12:14:46 +0100
commit823fc0fbb11e753520c5cf740bd106a38e775e59 (patch)
treeb02926501626f95c2868d9a7d0c0412f99741468
parentdb7c7281e93d6f42c624bb361786fbb5a292f8c9 (diff)
test suite: import-dsc: Test missing files, particularly in ..
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/tests/import-dsc22
2 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d7e003..769fa5c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,7 @@ dgit (3.12~) unstable; urgency=medium
Test suite:
* t-report-fail: print $PWD as part of failure message.
+ * import-dsc: Test missing files, particularly in ..
--
diff --git a/tests/tests/import-dsc b/tests/tests/import-dsc
index 073ba7b..bdd849c 100755
--- a/tests/tests/import-dsc
+++ b/tests/tests/import-dsc
@@ -72,6 +72,28 @@ git init
check-import $troot/pkg-srcs 1.0-1
+cd ..
+v=1.0-1+absurd
+rm -f ${p}_*
+dsc=$troot/pkg-srcs/${p}_${v}.dsc
+cd $p.2
+
+cp $dsc ..
+t-expect-fail 'it does not exist' \
+check-import .. $v
+
+mkdir ../enoents
+cp $dsc ../enoents
+t-expect-fail 'No such file or directory' \
+check-import ../enoents $v
+
+cd ..
+rm -f ${p}_${v}.dsc
+dget -du file://$dsc
+cd $p.2
+
+check-import .. $v
+
t-expect-fail "Your git tree does not have that object" \
check-import ../mirror/pool/main 1.2 --no-chase-dsc-distro