summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-16 12:52:05 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-16 17:42:03 +0100
commitb7120584994325d4f6d2963ed336110355349fc6 (patch)
treed4280367ce03d778adbc0528e0254e8dd4620d1b
parentf003a2342e846c512393749568fe85477a9f282a (diff)
When synthesing a commit from a .dsc from the archive, stop internal git reset from printing a confusing message about HEAD.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 30db5c9..46e23dc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -44,6 +44,8 @@ dgit (1.5~~) unstable; urgency=medium
messages. Closes:#800078.
* Pass --ch:* and -v options to dpkg-buildpackage when building
source. Fixes bad Perl poetry syntax. Closes:#829121.
+ * When synthesing a commit from a .dsc from the archive, stop
+ internal git reset from printing a confusing message about HEAD.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 81c5ff9..8404a19 100755
--- a/dgit
+++ b/dgit
@@ -1448,7 +1448,7 @@ END
my $cversion = getfield $clogp, 'Version';
progress "synthesised git commit from .dsc $cversion";
if ($lastpush_hash) {
- runcmd @git, qw(reset --hard), $lastpush_hash;
+ runcmd @git, qw(reset -q --hard), $lastpush_hash;
runcmd qw(sh -ec), 'dpkg-parsechangelog >>../changelogold.tmp';
my $oldclogp = parsecontrol('../changelogold.tmp','previous changelog');
my $oversion = getfield $oldclogp, 'Version';