summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 02:49:22 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-07 02:49:23 +0000
commitd422e614352724c8cd511c8d1ae8a6d9a1ba5265 (patch)
treed5b9e740e5c464dee1b66da453e48ff9103ea3fe
parent5ca654531c85b6bb69eb4a324dbe2244c2ac2a3a (diff)
dgit: Make clone_set_head not depend on $giturl
When cloning a distro which has no git server, correctly leave the user on the local dgit branch, not on `master'. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7daf4f3..c8f8155 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (2.10~) unstable; urgency=medium
* Test suite: Add fakeroot and make to Test-Depends. These aren't
necessarily pulled in by anything else. (dpkg-dev Recommends
build-essential. But we don't actually need build-essential.)
+ * When cloning a distro which has no git server, correctly leave
+ the user on the local dgit branch, not on `master'.
--
diff --git a/dgit b/dgit
index 0f9236c..f1a30c3 100755
--- a/dgit
+++ b/dgit
@@ -3096,9 +3096,9 @@ sub clone ($) {
mkdir $dstdir or fail "create \`$dstdir': $!";
changedir $dstdir;
runcmd @git, qw(init -q);
+ clone_set_head();
my $giturl = access_giturl(1);
if (defined $giturl) {
- clone_set_head();
runcmd @git, qw(remote add), 'origin', $giturl;
}
if ($hasgit) {